Re: suspend/resume support for PIT (time.c)

From: john stultz
Date: Mon Jan 12 2004 - 13:34:36 EST


On Sat, 2004-01-10 at 12:03, Pavel Machek wrote:
> +static int pit_suspend(struct sys_device *dev, u32 state)
[snip]
> +static int pit_resume(struct sys_device *dev)
> +{
> + write_seqlock_irq(&xtime_lock);
> + xtime.tv_sec = get_cmos_time() + clock_cmos_diff;
> + xtime.tv_nsec = 0;
> + write_sequnlock_irq(&xtime_lock);
> + return 0;
> +}
[snip]
> static struct sysdev_class pit_sysclass = {
> + .resume = pit_resume,
> + .suspend = pit_suspend,
> set_kset_name("pit"),
> };

As none of this really has anything to do w/ the PIT, and to avoid
confusion w/ the PIT timesource code, could we rename this to
"time_suspend" and "time_resume"?

thanks
-john



-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/