Re: [parisc-linux] Untested port of parisc_device to generic device interface

From: Greg KH (
Date: Wed Nov 13 2002 - 02:52:23 EST

On Wed, Nov 13, 2002 at 04:46:58PM +0900, Miles Bader wrote:
> Greg KH <> writes:
> > What is the real reason for needing this, pci_alloc_consistent()? We
> > have talked about renaming that to dev_alloc_consistent() in the past,
> > which I think will work for you, right?
> This this would end up [or have the ability to] invoking a bus-specific
> routine at some point, right? [so that a truly PCI-specific definition
> could be still be had]

If that was needed, yes, we should not break that functionality.

Are there any existing archs that need more than just dma_mask moved to
struct device out of pci_dev? Hm, ppc might need a bit more...


greg k-h
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

This archive was generated by hypermail 2b29 : Fri Nov 15 2002 - 22:00:28 EST