Re: [PATCH] rust: bindings: rename const binding using sed

From: Alice Ryhl
Date: Sun Oct 01 2023 - 08:18:09 EST


On 9/30/23 15:36, Gary Guo wrote:
Current for consts that bindgen don't recognise, we define a helper
constant with

const <TYPE> BINDINGS_<NAME> = <NAME>;

in `bindings_helper.h` and then we put

pub const <NAME>: <TYPE> = BINDINGS_<NAME>;

in `bindings/lib.rs`. This is fine that we currently only have 3
constants that are defined this way, but is going to be more annoying
when more constants are added since every new constant needs to be
defined in two places.

This patch changes the way we define constant helpers to

const <TYPE> RUST_BINDING_<NAME> = <NAME>;

and then use `sed` to postprocess Rust code by generated by bindgen to
remove the distinct prefix, so user of the binding crate can refer to
the name directly.

Maybe it would make sense to use a less generic name for this sed replacement? E.g., maybe RUST_CONST_HELPER_ or something that's less likely to overlap with things that are not constants.

Alice