RE: [PATCH v8 05/33] x86/traps: add external_interrupt() to dispatch external interrupts

From: Li, Xin3
Date: Mon Jun 19 2023 - 15:16:33 EST


> > Add external_interrupt() to dispatch external interrupts to their handlers.
> >
> > If an external interrupt is a system interrupt, dipatch it through
> > system_interrupt_handlers table, otherwise to
> > dispatch_common_interrupt().
>
> This naming convention sucks. external interrupts which can be system
> interrupts. Come on.

This name dispatch_common_interrupt() comes from arch/x86/kernel/irq.c:

/*
* common_interrupt() handles all normal device IRQ's (the special SMP
* cross-CPU interrupts have their own entry points).
*/
DEFINE_IDTENTRY_IRQ(common_interrupt)

Should we rename it to device_intertupt()?

Thanks!
Xin