Re: [PATCH] media: atomisp: ov2722: replace hardcoded function name

From: Greg Kroah-Hartman
Date: Wed Jan 06 2021 - 02:52:46 EST


On Tue, Jan 05, 2021 at 10:29:18PM +0200, Filip Kolev wrote:
> There is a debug message using hardcoded function name instead of the
> __func__ macro. Replace it.
>
> Report from checkpatch.pl on the file:
>
> WARNING: Prefer using '"%s...", __func__' to using 'ov2722_remove', this function's name, in a string
> + dev_dbg(&client->dev, "ov2722_remove...\n");
>
> Signed-off-by: Filip Kolev <fil.kolev@xxxxxxxxx>
> ---
> drivers/staging/media/atomisp/i2c/atomisp-ov2722.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/staging/media/atomisp/i2c/atomisp-ov2722.c b/drivers/staging/media/atomisp/i2c/atomisp-ov2722.c
> index eecefcd734d0e..21d6bc62d452a 100644
> --- a/drivers/staging/media/atomisp/i2c/atomisp-ov2722.c
> +++ b/drivers/staging/media/atomisp/i2c/atomisp-ov2722.c
> @@ -1175,7 +1175,7 @@ static int ov2722_remove(struct i2c_client *client)
> struct v4l2_subdev *sd = i2c_get_clientdata(client);
> struct ov2722_device *dev = to_ov2722_sensor(sd);
>
> - dev_dbg(&client->dev, "ov2722_remove...\n");
> + dev_dbg(&client->dev, "%s...\n", __func__);

dev_dbg() provides the function name already, and this is just a "trace"
call, and ftrace should be used instead, so the whole line should be
removed entirely.

thanks,

greg k-h