Re: [PATCH] div64.h: Fix description of do_div parameter

From: Jonathan NeuschÃfer
Date: Mon Feb 25 2019 - 10:51:32 EST


On Mon, Feb 25, 2019 at 04:19:02PM +0100, Geert Uytterhoeven wrote:
> Hi Jonathan,
>
> On Mon, Feb 25, 2019 at 3:05 PM Jonathan NeuschÃfer
> <j.neuschaefer@xxxxxxx> wrote:
> > Contrary to the description, the first parameter (n) should not be
> > passed as a pointer, but directly as an lvalue. This is possible because
> > do_div is a macro.
> >
> > Signed-off-by: Jonathan NeuschÃfer <j.neuschaefer@xxxxxxx>
>
> Thanks for your patch!
>
> Reviewed-by: Geert Uytterhoeven <geert+renesas@xxxxxxxxx>
>
> Shouldn't the "semantics" at the top of include/asm-generic/div64.h be
> updated, too?

Arguably, it's semantically close enough. I'm not sure.

> As this can't be expressed in a C function, perhaps that should be done
> using C++ syntax, like
>
> uint32_t do_div(uint64_t &n, uint32_t base)
> {
> ...
> }

That might confuse some people who aren't expecting C++ syntax.
I'll leave this as is, because I can't decide wether this is an
improvement.


Thanks,
Jonathan NeuschÃfer

Attachment: signature.asc
Description: PGP signature