Re: [PATCH] div64.h: Fix description of do_div parameter

From: Geert Uytterhoeven
Date: Mon Feb 25 2019 - 10:19:18 EST


Hi Jonathan,

On Mon, Feb 25, 2019 at 3:05 PM Jonathan NeuschÃfer
<j.neuschaefer@xxxxxxx> wrote:
> Contrary to the description, the first parameter (n) should not be
> passed as a pointer, but directly as an lvalue. This is possible because
> do_div is a macro.
>
> Signed-off-by: Jonathan NeuschÃfer <j.neuschaefer@xxxxxxx>

Thanks for your patch!

Reviewed-by: Geert Uytterhoeven <geert+renesas@xxxxxxxxx>

Shouldn't the "semantics" at the top of include/asm-generic/div64.h be
updated, too?

As this can't be expressed in a C function, perhaps that should be done
using C++ syntax, like

uint32_t do_div(uint64_t &n, uint32_t base)
{
...
}

Gr{oetje,eeting}s,

Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@xxxxxxxxxxxxxx

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds