Re: [RFC][PATCH 6/8] perf: Per PMU disable

From: Peter Zijlstra
Date: Fri Jun 18 2010 - 03:12:21 EST


On Fri, 2010-06-18 at 04:14 +0200, Frederic Weisbecker wrote:
> On Wed, Jun 16, 2010 at 06:00:33PM +0200, Peter Zijlstra wrote:
> > +static void armpmu_pmu_enable(struct pmu *pmu)
> > {
> > +static void powerpc_pmu_pmu_disable(struct pmu *pmu)
> > {
> > +static void fsl_emb_pmu_pmu_disable(struct pmu *pmu)
> > {
> > +static void sh_pmu_pmu_enable(struct pmu *pmu)
> > +{
> > +static void sparc_pmu_pmu_enable(struct pmu *pmu)
> > {
> > +static void x86_pmu_pmu_disable(struct pmu *pmu)
> > {
>
>
> These namings are really bad. Why not just using pmu once
> in each names? x86_pmu_enable, etc...

Because some of those were already taken:

static const struct pmu pmu = {
.enable = x86_pmu_enable,
.disable = x86_pmu_disable,

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/