Re: Coding style RFC: convert "for (i=0;i<ARRAY_SIZE(array);i++)"to "array_for_each(index, array)"

From: Bernd Petrovitsch
Date: Tue Feb 13 2007 - 05:37:06 EST


On Tue, 2007-02-13 at 18:42 +1100, Nick Piggin wrote:
> Joe Perches wrote:
[...]
> > perhaps:
> >
> > #define array_for_each(element, array) \
> > for ((element) = (array); \
> > (element) < ((array) + ARRAY_SIZE((array))); \
> > (element)++)
>
> If you're going for consistency, then shouldn't this be
> array_for_each_entry()?

That depends on the decision between consistency to array_for_each_index
or consistency to list_for_each.

> > #define array_for_each_index(index, array) \
> > for ((index) = 0; (index) < ARRAY_SIZE((array)); (index)++)

Bernd
--
Firmix Software GmbH http://www.firmix.at/
mobil: +43 664 4416156 fax: +43 1 7890849-55
Embedded Linux Development and Services

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/