Re: Proposed changes to generic blk tag for use in SCSI (1/3)

From: Jens Axboe (
Date: Tue Jun 11 2002 - 09:45:06 EST

On Tue, Jun 11 2002, James Bottomley wrote:
> said:
> > Ehm it's already there, one could argue that it's pretty core
> > functionality for this type of stuff :-). It's called
> > blk_queue_get_tag(q, tag), and it's in blkdev.h. However, I agree that
> > we should just move it into ll_rw_blk.c. That gets better documented
> > as well. Could you redo that part?
> I guessed it must be. I grepped the IDE tree looking for anything with `get'
> or `find' in it, but came up empty. It's actually called
> blk_queue_tag_request(), which is why I didn't find it.
> Do you want me to keep this name if I move it?

Nah the name sucks, you see I didn't even remember it myself either. Why
not just change the name to something sane, like blk_queue_get_tag() or
blk_queue_find_tag(). I think yours (the latter) describes it best. Just
ide accordingly as well, that's the sole current user.

> said:
> > I completely agree with this, blk_queue_start_tag() should not need to
> > know about these things so just checking if the request is already
> > marked tagged is fine with me. But please make that a warning, like
> Actually, I think it should be a BUG(). By the time a tagged request
> comes in to blk_queue_start_tag, we must already have corrupted the
> lists since we use the same list element (req->queuelist) to queue on
> both the tag queue and the request queue.

Agree, make it a BUG_ON() or something.

> > And also _please_ fix the comment about REQ_CMD and not just the code,
> > it's doesn't stand anymore.
> Will do...I didn't see much point altering the comment in the
> prototype until there was agreement that it was OK to do it this way.


Jens Axboe

- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to More majordomo info at Please read the FAQ at

This archive was generated by hypermail 2b29 : Sat Jun 15 2002 - 22:00:22 EST