Re: [PATCH] change name of rep_nop

From: Etienne Lorrain (
Date: Tue Oct 09 2001 - 03:51:40 EST

> __asm__ __volatile__("rep;nop");

"The behavior of the REP prefix is undefined when used with non-string
instructions." page 3-404 of Intel documentation, in "CHAPTER 3,

  How about: __asm__ __volatile__("loop ." : "+c" (nbloop)); ?


Un nouveau Nokia Game commence.
Allez sur avant le 3 novembre
pour participer à cette aventure tous médias.
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

This archive was generated by hypermail 2b29 : Mon Oct 15 2001 - 21:00:23 EST