Re: [PATCH 2.4.5-ac12] New Sony Vaio Motion Eye camera driver

From: Stelian Pop (stelian.pop@fr.alcove.com)
Date: Fri Jun 29 2001 - 04:29:04 EST


On Thu, Jun 28, 2001 at 03:11:22PM -0400, volodya@mindspring.com wrote:

> I imagine it is either using ZV port or VIP/MPP connector - I'll be happy
> to help you to get it to work, provided you know the part that produces
> video stream.

This part is described in the chip's doc here:
        http://va.samba.org/picturebook/72002_E_.pdf

Look at the page 9 where the connections between the chip and
the video bus are described. The problem is that there are 2 possible
modes (ZV-port or Digital YC), and I'm not sure which one Sony
chose to use...

> > Well, not quite... I've had several X lockups while using the YUV
> > acceleration code. Let's say one lockup per half an hour.
>
> That's not supposed to happen - let me know what causes it.. what you are
> using, etc..

The lockups happen upon closing xawtv (used with xv output). Let's
say one time in ten runs... Then the X server is dead, but I can
still log in using the network and do whatever I want. But if I kill
the X server the whole system freezes hard.

> > but in 640x480 the framerate achieved with Xv is below the
> > one I get by converting YUV->RGB in software...
>
> You have to be careful here - you can't write to the framebuffer without
> waiting for engine to go idle. Otherwise it'll lockup.

??? That's not me, it's xawtv, through the XV facilities of the
X server which writes to the framebuffer... Or maybe I don't
understand the question...

Anyway, I've retested it with the latest ati.2 binaries and how
the 640x480 xv speed seems to have improved (or something in
my configuration changed, of course :-) ).

> > (but no X driver recognizes this connector today). The motion jpeg
> > chip this camera is based on definately has a video output.
>
> I can help you get this to work.

I'd like to, thanks.

> > Or it could just be the application who gets YUV data from the chip
> > then send it directly to the video board. Today this works, almost
> > (because we need a patched X - read gatos - and a patched xawtv - in
> > order to do scaling).
>
> Try using xv_stream from ati_xv branch on gatos.

It won't work out of the box either (it uses only v4l read calls and
doesn't support mmap, it assumes a capture size of 352x288 which this
camera does not support etc). But it should be easy to patch it and
make it work with this camera, just like I did with xawtv.

Stelian.

PS: this hasn't much to do with the kernel anymore, I suggest we
take this discussion off list now. I'm not sure neither if Linus
is really interested in getting a copy of this. :-)

-- 
Stelian Pop <stelian.pop@fr.alcove.com>
|---------------- Free Software Engineer -----------------|
| Alc˘ve - http://www.alcove.com - Tel: +33 1 49 22 68 00 |
|------------- Alc˘ve, liberating software ---------------|
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/



This archive was generated by hypermail 2b29 : Sat Jun 30 2001 - 21:00:21 EST