From: Cesar Eduardo Barros (
Date: Sat Aug 26 2000 - 15:51:23 EST

I recently decided to take a look at the partition code, which I could recall
being in drivers/block/genhd.c. Looking there, I had the surprise to see it had
only one function, whose beggining was:

void __init device_init(void)

This clearly doesn't belong into drivers/block! And genhd.c is a completely
misleading name for it (unless you think the comment pointing at fs/partitions
is the most important part of it).

So I think it should be moved to init/ with a new name (init.c?), or maybe even
moved inside main.c (which I think would be the ideal fix).

Cesar Eduardo Barros
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
Please read the FAQ at

This archive was generated by hypermail 2b29 : Thu Aug 31 2000 - 21:00:18 EST