Re: [PATCH] final support for MODULE_PARAM as kernel commandline

David Hinds (dhinds@zen.stanford.edu)
Mon, 13 Sep 1999 18:05:31 -0700


I think this is generally a GREAT thing, and something I've wanted for
a long time, but never got around to doing.

However... I think we can't just grab the module parameter name and
use that as a boot parameter name: each module currently has its own
"namespace" for parameters, and you're going to get tons of conflicts
this way. For instance, there are tons of things like:

MODULE_PARM(io, "i");
MODULE_PARM(debug, "i");

etc.

There are two options for dealing with this: either invent a standard
naming convention (i.e., "io" becomes "3c501_io") and live with that
for both module parameters and boot parameters, or, have a way of
specifying a prefix just for boot parameters, like:

__setup(MODULE_PREFIX #var "=", modparm##var##_setup);

I tend to prefer the prefix thing because I think it would cause less
disruption. Module parameters could still use the short form everyone
expects. Driver updates would consist of just adding a macro for the
prefix.

It would also be nice to parse more of the argument classes, including
the array-of-int things. But that can be added later.

-- Dave Hinds

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.rutgers.edu
Please read the FAQ at http://www.tux.org/lkml/