Re: [Q] README.tunnel? new_tunnel/tunnel.o ? [2.1.119]

kuznet@ms2.inr.ac.ru
Thu, 10 Sep 1998 23:18:23 +0400 (MSK DST)


Hello!

> I see. I assume you mean that the README is misleading because it implies
> ipip works when it really doesn't?

It works differently. You can parse maillists to find, how it works.

I appended some mails from my mailbox. Do not be confused
by word "gre", "ipip" works exactly in the same way, only
word "gre" is replaced with "ipip"

Shortly, the thing, which was:

ifconfig tunlX A pointopoint B

is translated as:

ip tunnel add tunlX mode ipip remote B
ifconfig tunlX A

Alexey

> Subject: Re: Kernel 2.1 and ip tunnel
> To: jr@mpoli.fi
> Date: Sat, 4 Jul 1998 18:00:41 +0400 (MSK DST)
> In-Reply-To: <199807041200.PAA02684@unix.mpoli.fi> from "Johan Ronkainen" at Jul 4, 98 03:00:40 pm
> X-Mailer: ELM [version 2.4 PL24]
> MIME-Version: 1.0
> Content-Length: 1529
>
> Hello!
>
> > Hi. I tried to install ip-tunnel between linux and cisco and having some
> > problems at linux end. IPIP tunnel with kernel 2.0.34 "works" but large
> > transfers (over 500k ftp) causes cisco to hang 10-15sec period.
>
> Probably, it is Cisco problem.
>
> > I noticed
> > that 2.1.108 has new tunnel code and ipgre support. Couldn't find any
> > documentation on net how ipip or ipgre tunnel should be configured on 2.1
> > series kernels. Downloaded your iproute2 (980613+glibc2 fixes), compiled but
> > then what? I tried syntax like "ip tunnel add gre mode gre remote <cisco-ip>
> > local <local-ip> dev eth0" and a lot of other syntaxes without luck.
> >
> > So if you could point me to some web site or file which contains somekind of
> > sample tunneling setup it would be helpful.
>
> There is no documentation except for helper built in ip utility.
> It is not a big problem because "ip tunnel" logic is very close
> to IOS logic. If you was able to configure Cisco,
> you should not have any problems with configuring Linux.
> If you never did it, look at IOS manual (f.e. http://www.cisco.com).
>
> Then Cisco:
>
> interface Tunnel0
> tunnel mode gre ip
> tunnel destination a.b.c.d
> tunnel source e.f.g.h
>
> is equivalent to Linux:
>
> ip tunnel add Tunnel0 mode gre remote a.b.c.d local e.f.g.h
>
> No magic 8) The rest of options are translated even more easily.
>
> Interface addresses, routes etc. are set on newly created
> tunnel exactly as it is done for another interfaces.
> You may make it with ifconfig or ip utility, depending what style
> you prefer.
>
> Alexey

> Subject: Re: ipip/gre (fwd)
> To: wembly@doxx.net
> Date: Wed, 12 Aug 1998 17:18:45 +0400 (MSK DST)
> In-Reply-To: <Pine.LNX.3.96.980811133351.8995A-100000@arsenic.doxx.net> from "Wembly L. Panther" at Aug 11, 98 01:41:17 pm
> X-Mailer: ELM [version 2.4 PL24]
> MIME-Version: 1.0
> Content-Length: 1220
>
> Hello!
>
> > im working with your gre tunnel and trying to add a few things.
> > so far iv managed to have more then one gre interface
> > but can more then one tunnel (from system a to system b and system a to
> > system c) exist with only one interface? or do you need two interfaces?
>
> Not necessary. You may create NBMA tunnel by:
>
> ip tunnel add XXXXX mode gre local A
>
> and then add routes via B and B:
>
> ip route add SOME-NET1 via B dev XXXXX onlink
> ip route add SOME-NET2 via C dev XXXXX onlink
>
> etc. Note "onlink" keyword, it is necessary in order
> kernel not to refuse these routes.
>
> But I do not recommend this way: pure PtP tunnels
> have much of advantages, sort of PMTU discovery and icmp
> relaying, which do not work for NBMA tunnels.
>
> > i was thinking of encrypted ip possably.
>
> This case is covered by IPsec.
> Simpler variants (CIPE etc.) already exist in form of patches.
>
> > or ipx over ip or something.
> > no clue i was just wondering if there's plans on working on more tunnels
> > for diffrnt protocols.
>
> In theory gre over ip works for any protocol, provided corresponding
> protocol (f.e. ipx or ddp) will understand it correctly, if it does not,
> it is problem of tunneled protocol, rather than IP.
>
> Alexey Kuznetsov

> Subject: Re: GRE over IP
> To: teknix@alloy.net (Teknix)
> Date: Wed, 2 Sep 1998 13:48:51 +0400 (MSK DST)
> In-Reply-To: <Pine.GSO.4.02.9809012028150.2583-100000@mercury.alloy.net> from "Teknix" at Sep 1, 98 09:24:38 pm
> X-Mailer: ELM [version 2.4 PL24]
> MIME-Version: 1.0
> Content-Length: 3905
>
> Hello!
>
> You configured gre tunnel incorrectly.
>
> > brought up. I think the kernel "automagically" configures it. I have not
> > been able to remove it with route or your "ip route" utility.
>
> You need not remove it (though it is possible).
>
> I appended two my answers to similar questions.
> I hope, they will help you.
>
> If you will fail, then send me configuration on Cisco
> side, I'll translate it to Linux language.
>
> Alexey
>
> >
> > From kuznet Wed Mar 4 17:35:27 1998
> > Subject: Re: linux GRE tunnels
> > To: ltd@interlink.com.au (Lincoln Dale)
> > Date: Wed, 4 Mar 1998 17:35:27 +0300 (MSK)
> > Cc: Alan.Cox@linux.org
> > In-Reply-To: <199803041018.SAA17151@techpkwa2.curtin.edu.au> from "Lincoln Dale" at Mar 4, 98 06:18:05 pm
> > X-Mailer: ELM [version 2.4 PL24]
> > MIME-Version: 1.0
> > Content-Length: 1090
> > Status: RO
> >
> > Hello!
> >
> > > cisco configuration is as:
> > > ..
> > > int tunnel0
> > > ip address 192.168.1.1 255.255.255.252
> > > tunnel mode gre ip
> > > tunnel source fddi4/0
> > > tunnel destination 24.192.15.145
> > > ..
> >
> > Cisco "tunnel ???" commands are subset of Linux "ip tunnel ???" commands.
> > (ip utility can be found at ftp://ftp.inr.ac.ru/ip-routing/iproute2-current.tar.gz
> > Linux ifconfig is equivalent to Cisco "ip address".
> > (or "ip address ..." of iproute2)
> >
> > F.e. in linux the same thing would look like:
> >
> > ip tunnel add tunnel0 mode gre remote 24.192.14.145 \
> > local <primary address on Cisco's fddi4/0>
> >
> > and
> >
> > ifconfig tunnel0 192.168.1.1 netmask 255.255.255.252
> > or
> > ip addr add 192.168.1.1/30 dev tunnel0
> > ip link set tunnel0 up
> >
> > > linux configuration is:
> > > ifconfig gre0 192.168.1.2 netmask 255.255.255.252
> > > route add -host 24.192.7.253 eth0
> > > route add -host 192.168.1.1 gre
> >
> > ip tunnel add gre1 mode gre remote <Cisco fddi4/0> local 24.192.15.145
> >
> > ifconfig gre1 192.168.1.2 netmask 255.255.255.252
> > or
> > ip addr add 192.168.1.2/30 dev gre1
> > ip link set gre1 up
> >
> > That's all.
> >
> > Alexey Kuznetsov

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.rutgers.edu
Please read the FAQ at http://www.tux.org/lkml/faq.html