oops on 2.1.10[23] at boot-time, oops in 2.1.101 after system idle

Jan Kneschke (Jan.Kneschke@kiel.netsurf.de)
Sat, 23 May 1998 07:49:44 +0200 (MEST)


i tried to compile an 2.1.10[23], because ip-forwarding in 2.1.101 was
unstable. while tranfering a 27 MB-file from one network to another both
nic's died at round about 10 MB. i got no replies on pings anymore.
after reboot everything was fine again.

first problem is awk which dies with a seg-fault while 'make menuconfig'.
'make config' works. here is the output of make menuconfig:

rm -f include/asm
( cd include ; ln -sf asm-i386 asm)
make -C scripts/lxdialog all
make[1]: Entering directory /linux2/home/weigon/linux-new/scripts/lxdialog'
make[1]: Leaving directory /linux2/home/weigon/linux-new/scripts/lxdialog'
/bin/sh scripts/Menuconfig arch/i386/config.in
Using defaults found in .config
Preparing configuration scripts: version, functions,parsingscripts/Menuconfig:
line 1: 637 Segmentation fault (core dumped) awk "$1"
Awk died with error code 139. Giving up.
...scripts/Menuconfig: ./MCmenu10: line 96: unexpected EOF while looking for
matching "'
scripts/Menuconfig: ./MCmenu10: line 97: syntax error: unexpected end of
file
......scripts/Menuconfig: ./MCmenu16: line 92: syntax error: unexpected end
of file
..scripts/Menuconfig: ./MCmenu18: line 163: syntax error: unexpected end of
file......scripts/Menuconfig: ./MCmenu6: line 89: syntax error: unexpected
end of file
.scripts/Menuconfig: ./MCmenu7: line 106: syntax error: unexpected end of
file
..scripts/Menuconfig: ./MCmenu9: line 75: unexpected EOF while looking for
matching "'
scripts/Menuconfig: ./MCmenu9: line 76: syntax error: unexpected end of file
done.

after that an empty menu comes up containing "load" and "save", only.
here is the output of gdb on awk using the core-file:

Core was generated by `awk
BEGIN {
menu_no = 0
comment_is_option = 0
parser("arch/i386/config.in",'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /lib/libm.so.5...done.
Reading symbols from /lib/libc.so.5...done.
Reading symbols from /lib/ld-linux.so.1...done.
#0 0x8055540 in catchsig ()
(gdb) bt
#0 0x8055540 in catchsig ()
#1 0x40038cae in _IO_vsprintf (
string=0x804e5cf "\211^ \203\f\213F\030\203\203L\017\207\006",
format=0xbf80036c "", args=0x8066842)
#2 0xbf80036c in ?? ()

so, i compiled an 2.1.102 using 'make config' for the configuration-part.
this kernel gives me an oops at boot-time, but the kernel is still running.
i tried to fix this by using .103, but that kernel locks
solid after the detection of the piix3. (oops in swapper like here)

so, here is my boot.msg for the 2.1.102:

Loaded 5906 symbols from /usr/src/linux/System.map.
Symbols match kernel version.
klogd 1.3-0, log source = /proc/kmsg started.
<4>Linux version 2.1.102 (weigon@weigon) (gcc version 2.7.2.1) #25 SMP Sat May 23 06:06:17 MEST 1998
<4>Console: 16 point font, 400 scans
<4>Console: colour VGA+ 80x25, 1 virtual console (max 63)
<4>Calibrating delay loop... 59.80 BogoMIPS
<4>Memory: 47084k/49152k available (848k kernel code, 400k reserved, 780k data, 40k init)
<6>Swansea University Computer Society NET3.039 for Linux 2.1
<6>NET3: Unix domain sockets 0.16 for Linux NET3.038.
<6>Swansea University Computer Society TCP/IP for NET3.037
<6>IP Protocols: ICMP, UDP, TCP
<6>Checking 386/387 coupling... Ok, fpu using exception 16 error reporting.
<6>Checking 'hlt' instruction... Ok.
<6>Intel Pentium with F0 0F bug - workaround enabled.
<4>POSIX conformance testing by UNIFIX
<4>CPU0: Intel Pentium 75+ stepping 0c
<5>SMP motherboard not detected. Using dummy APIC emulation.
<4>PCI: PCI BIOS revision 2.10 entry at 0xfb3b0
<4>PCI: Using configuration type 1
<4>PCI: Probing PCI hardware.
<4>Starting kswapd v 1.5
<6>Serial driver version 4.25 with enabled
<6>ttyS00 at 0x03f8 (irq = 4) is a 16550A
<6>ttyS01 at 0x02f8 (irq = 3) is a 16550A
<1>Unable to handle kernel NULL pointer dereference at virtual address 00000008
<1>current->tss.cr3 = 00101000, Xr3 = 00101000
<1>*pde = 00000000
<4>Oops: 0000
<4>CPU: 0
<4>EIP: 0010:[<c0131891>]
<4>EFLAGS: 00010202
<4>eax: fffffffe ebx: 00000020 ecx: c0092000 edx: 00000000
<4>esi: c0092001 edi: 00000000 ebp: 00000001 esp: c0095dc0
<4>ds: 0018 es: 0018 ss: 0018
<4>Process swapper (pid: 4, process nr: 4, stackpage=c0095000)
<4>Stack: 00000020 c0092000 00000000 c01db640 f1ace860 e801faa1 53bafee5 f1a0e860
<4> 338ca2bf fe13e8c0 fed3e850 c0131ada c0092000 00000000 00000001 00000020
<4> c0092000 c0092000 c01db640 45851eb6 00008000 c0130a03 c0092000 00000000
<4>Call Trace: [<c0131ada>] [<c0130a03>] [<c0131538>] [<c0108b07>] [<c01cd7c2>] [<c0109e48>] [<c01cd7c2>]
<4> [<c011d962>] [<c0106000>] [<c01bcb10>] [<c01bcb13>] [<c01cd7c2>] [<c011d9cd>] [<c01cd7c2>] [<c011d7e8>]
<4>Code: 8b 4f 08 85 c9 0f 84 4c 01 00 00 b8 ec ff ff ff 8b 51 58 85
<6>lp: driver loaded but no devices found
<6>js: no joysticks found
<4>PIIX3: IDE controller on PCI bus 00 dev 39
<4>PIIX3: not 100ative mode: will probe irqs later
<4> ide0: BM-DMA at 0xf000-0xf007, BIOS settings: hda:pio, hdb:pio
<4> ide1: BM-DMA at 0xf008-0xf00f, BIOS settings: hdc:pio, hdd:pio
<4>hda: QUANTUM TRB850A, ATA DISK drive
<4>hdb: QUANTUM FIREBALL ST4.3A, ATA DISK drive
<4>hdc: FX001DE, ATAPI CDROM drive
<4>ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
<4>ide1 at 0x170-0x177,0x376 on irq 15
<6>hda: QUANTUM TRB850A, 810MB w/96kB Cache, CHS=1647/16/63, DMA
<6>hdb: QUANTUM FIREBALL ST4.3A, 4110MB w/81kB Cache, CHS=524/255/63, DMA
<4>hdc: ATAPI 4X CDROM drive, 128kB Cache
<6>Uniform CD-ROM driver Revision: 2.12
<4>ne.c: PCI BIOS reports Realtek 8029 at i/o 0x6100, irq 11.
<4>ne.c:v1.10 9/23/94 Donald Becker (becker@cesdis.gsfc.nasa.gov)
<4>NE*000 ethercard probe at 0x6100: 00 00 b4 5b bb 8a
<4>eth0: NE2000 found at 0x6100, using IRQ 11.
<4>Partition check:
<4> hda: hda1 hda2 hda3
<4> hdb: hdb1 hdb2 hdb3
<4>VFS: Mounted root (ext2 filesystem) readonly.
<4>Freeing unused kernel memory: 40k freed
<4>Adding Swap: 20660k swap-space (priority -1)
<4>Adding Swap: 104416k swap-space (priority -2)
Kernel logging (proc) stopped.
Kernel log daemon terminating.

here is the output of ksymoops for this oops:

Using `linux/System.map' to map addresses to symbols.

>>EIP: c0131891 <lookup_dentry+75/1e8>
Trace: c0131ada <open_namei+56/2bc>
Trace: c0130a03 <do_execve+43/1d8>
Trace: c0131538 <getname+90/ec>
Trace: c0108b07 <sys_execve+9b/d0>
Trace: c01cd7c2 <NR_TYPES+a7e/2566>
Trace: c0109e48 <system_call+38/40>
Trace: c01cd7c2 <NR_TYPES+a7e/2566>
Trace: c011d962 <exec_modprobe+17a/1c4>
Trace: c0106000 <this_must_match_init_task>
Trace: c01bcb10 <tvecs+938/8c17>
Trace: c01bcb13 <tvecs+93b/8c17>
Trace: c01cd7c2 <NR_TYPES+a7e/2566>
Trace: c011d9cd <request_module+21/88>
Trace: c01cd7c2 <NR_TYPES+a7e/2566>
Trace: c011d962 <exec_modprobe+17a/1c4>
Code: c0131891 <lookup_dentry+75/1e8>
Code: c0131891 <lookup_dentry+75/1e8> 8b 4f 08 movl 0x8(%edi),%ecx
Code: c0131894 <lookup_dentry+78/1e8> 85 c9 testl %ecx,%ecx
Code: c0131896 <lookup_dentry+7a/1e8> 0f 84 4c 01 00 je c01319e8 <lookup_dentry+1cc/1e8>
Code: c01318a2 <lookup_dentry+86/1e8> b8 ec ff ff ff movl $0xffffffec,%eax
Code: c01318a7 <lookup_dentry+8b/1e8> 8b 51 58 movl 0x58(%ecx),%edx
Code: c01318aa <lookup_dentry+8e/1e8> 85 00 testl %eax,(%eax)
Code: c01318b2 <lookup_dentry+96/1e8> 90 nop
Code: c01318b3 <lookup_dentry+97/1e8> 90 nop
Code: c01318b4 <lookup_dentry+98/1e8> 90 nop

and to complete the bug-report, here is my .config.h

#
# Automatically generated make config: don't edit
#

#
# Code maturity level options
#
CONFIG_EXPERIMENTAL=y

#
# Processor type and features
#
# CONFIG_M386 is not set
# CONFIG_M486 is not set
CONFIG_M586=y
# CONFIG_M686 is not set
# CONFIG_MATH_EMULATION is not set
# CONFIG_MTRR is not set

#
# Loadable module support
#
CONFIG_MODULES=y
# CONFIG_MODVERSIONS is not set
CONFIG_KMOD=y

#
# General setup
#
CONFIG_NET=y
CONFIG_PCI=y
CONFIG_PCI_BIOS=y
CONFIG_PCI_DIRECT=y
# CONFIG_PCI_QUIRKS is not set
# CONFIG_PCI_OLD_PROC is not set
# CONFIG_MCA is not set
CONFIG_SYSVIPC=y
CONFIG_BSD_PROCESS_ACCT=y
CONFIG_SYSCTL=y
CONFIG_BINFMT_AOUT=m
CONFIG_BINFMT_ELF=y
CONFIG_BINFMT_MISC=m
# CONFIG_BINFMT_JAVA is not set
CONFIG_VIDEO_SELECT=y
CONFIG_PARPORT=y
CONFIG_PARPORT_PC=m
# CONFIG_PARPORT_OTHER is not set

#
# Plug and Play support
#
CONFIG_PNP=y
CONFIG_PNP_PARPORT=y

#
# Block devices
#
CONFIG_BLK_DEV_FD=m
CONFIG_BLK_DEV_IDE=y

#
# Please see Documentation/ide.txt for help/info on IDE drives
#
# CONFIG_BLK_DEV_HD_IDE is not set
CONFIG_BLK_DEV_IDEDISK=y
CONFIG_BLK_DEV_IDECD=y
# CONFIG_BLK_DEV_IDETAPE is not set
# CONFIG_BLK_DEV_IDEFLOPPY is not set
# CONFIG_BLK_DEV_IDESCSI is not set
# CONFIG_BLK_DEV_CMD640 is not set
# CONFIG_BLK_DEV_RZ1000 is not set
CONFIG_BLK_DEV_IDEPCI=y
CONFIG_BLK_DEV_IDEDMA=y
# CONFIG_BLK_DEV_OPTI621 is not set
# CONFIG_BLK_DEV_TRM290 is not set
# CONFIG_BLK_DEV_NS87415 is not set
# CONFIG_IDE_CHIPSETS is not set

#
# Additional Block Devices
#
# CONFIG_BLK_DEV_LOOP is not set
# CONFIG_BLK_DEV_NBD is not set
# CONFIG_BLK_DEV_MD is not set
# CONFIG_BLK_DEV_RAM is not set
# CONFIG_BLK_DEV_XD is not set
CONFIG_PARIDE_PARPORT=y
# CONFIG_PARIDE is not set
# CONFIG_BLK_DEV_HD is not set

#
# Networking options
#
CONFIG_PACKET=y
# CONFIG_NETLINK is not set
# CONFIG_FIREWALL is not set
# CONFIG_NET_ALIAS is not set
# CONFIG_FILTER is not set
CONFIG_UNIX=y
CONFIG_INET=y
# CONFIG_IP_MULTICAST is not set
# CONFIG_IP_ADVANCED_ROUTER is not set
# CONFIG_IP_PNP is not set
# CONFIG_IP_ROUTER is not set
# CONFIG_NET_IPIP is not set
# CONFIG_NET_IPGRE is not set
# CONFIG_IP_ALIAS is not set
CONFIG_SYN_COOKIES=y

#
# (it is safe to leave these untouched)
#
# CONFIG_INET_RARP is not set
CONFIG_IP_NOSR=y
CONFIG_SKB_LARGE=y
# CONFIG_IPV6 is not set

#
#
#
# CONFIG_IPX is not set
# CONFIG_ATALK is not set
# CONFIG_X25 is not set
# CONFIG_LAPB is not set
# CONFIG_BRIDGE is not set
# CONFIG_LLC is not set
# CONFIG_ECONET is not set
# CONFIG_WAN_ROUTER is not set
# CONFIG_NET_FASTROUTE is not set
# CONFIG_NET_HW_FLOWCONTROL is not set
# CONFIG_CPU_IS_SLOW is not set
# CONFIG_NET_SCHED is not set
# CONFIG_NET_PROFILE is not set

#
# SCSI support
#
# CONFIG_SCSI is not set

#
# Network device support
#
CONFIG_NETDEVICES=y
# CONFIG_ARCNET is not set
CONFIG_DUMMY=m
# CONFIG_EQUALIZER is not set
CONFIG_NET_ETHERNET=y
# CONFIG_NET_VENDOR_3COM is not set
# CONFIG_LANCE is not set
# CONFIG_NET_VENDOR_SMC is not set
# CONFIG_NET_VENDOR_RACAL is not set
# CONFIG_RTL8139 is not set
# CONFIG_YELLOWFIN is not set
CONFIG_NET_ISA=y
# CONFIG_AT1700 is not set
# CONFIG_E2100 is not set
# CONFIG_DEPCA is not set
# CONFIG_EWRK3 is not set
# CONFIG_EEXPRESS is not set
# CONFIG_EEXPRESS_PRO is not set
# CONFIG_FMV18X is not set
# CONFIG_HPLAN_PLUS is not set
# CONFIG_HPLAN is not set
# CONFIG_HP100 is not set
# CONFIG_ETH16I is not set
CONFIG_NE2000=y
# CONFIG_SEEQ8005 is not set
# CONFIG_SK_G16 is not set
# CONFIG_NET_EISA is not set
# CONFIG_NET_POCKET is not set
# CONFIG_FDDI is not set
# CONFIG_DLCI is not set
# CONFIG_PLIP is not set
CONFIG_PPP=m

#
# CCP compressors for PPP are only built as modules.
#
# CONFIG_SLIP is not set
# CONFIG_NET_RADIO is not set
# CONFIG_TR is not set
# CONFIG_SHAPER is not set

#
# Amateur Radio support
#
# CONFIG_HAMRADIO is not set

#
# ISDN subsystem
#
# CONFIG_ISDN is not set

#
# CD-ROM drivers (not for SCSI or IDE/ATAPI drives)
#
# CONFIG_CD_NO_IDESCSI is not set

#
# Filesystems
#
# CONFIG_QUOTA is not set
CONFIG_MINIX_FS=m
CONFIG_EXT2_FS=y
CONFIG_ISO9660_FS=y
CONFIG_JOLIET=y
CONFIG_FAT_FS=y
CONFIG_MSDOS_FS=y
# CONFIG_UMSDOS_FS is not set
CONFIG_VFAT_FS=y
CONFIG_PROC_FS=y
CONFIG_NFS_FS=y
# CONFIG_NFSD is not set
CONFIG_SUNRPC=y
CONFIG_LOCKD=y
# CONFIG_CODA_FS is not set
CONFIG_SMB_FS=m
CONFIG_SMB_WIN95=y
# CONFIG_HPFS_FS is not set
# CONFIG_NTFS_FS is not set
# CONFIG_SYSV_FS is not set
# CONFIG_AFFS_FS is not set
# CONFIG_HFS_FS is not set
# CONFIG_ROMFS_FS is not set
CONFIG_AUTOFS_FS=y
# CONFIG_UFS_FS is not set
# CONFIG_ADFS_FS is not set
# CONFIG_DEVPTS_FS is not set
# CONFIG_MAC_PARTITION is not set
CONFIG_NLS=y

#
# Native Language Support
#
CONFIG_NLS_CODEPAGE_437=m
# CONFIG_NLS_CODEPAGE_737 is not set
# CONFIG_NLS_CODEPAGE_775 is not set
CONFIG_NLS_CODEPAGE_850=y
# CONFIG_NLS_CODEPAGE_852 is not set
# CONFIG_NLS_CODEPAGE_855 is not set
# CONFIG_NLS_CODEPAGE_857 is not set
# CONFIG_NLS_CODEPAGE_860 is not set
# CONFIG_NLS_CODEPAGE_861 is not set
# CONFIG_NLS_CODEPAGE_862 is not set
# CONFIG_NLS_CODEPAGE_863 is not set
# CONFIG_NLS_CODEPAGE_864 is not set
# CONFIG_NLS_CODEPAGE_865 is not set
# CONFIG_NLS_CODEPAGE_866 is not set
# CONFIG_NLS_CODEPAGE_869 is not set
# CONFIG_NLS_CODEPAGE_874 is not set
CONFIG_NLS_ISO8859_1=y
# CONFIG_NLS_ISO8859_2 is not set
# CONFIG_NLS_ISO8859_3 is not set
# CONFIG_NLS_ISO8859_4 is not set
# CONFIG_NLS_ISO8859_5 is not set
# CONFIG_NLS_ISO8859_6 is not set
# CONFIG_NLS_ISO8859_7 is not set
# CONFIG_NLS_ISO8859_8 is not set
# CONFIG_NLS_ISO8859_9 is not set
# CONFIG_NLS_KOI8_R is not set

#
# Character devices
#
CONFIG_VT=y
CONFIG_VT_CONSOLE=y
CONFIG_SERIAL=y
CONFIG_SERIAL_CONSOLE=y
# CONFIG_SERIAL_EXTENDED is not set
# CONFIG_SERIAL_NONSTANDARD is not set
CONFIG_PRINTER=y
CONFIG_PRINTER_READBACK=y
# CONFIG_MOUSE is not set
# CONFIG_UMISC is not set
# CONFIG_QIC02_TAPE is not set
# CONFIG_APM is not set
# CONFIG_WATCHDOG is not set
# CONFIG_RTC is not set
# CONFIG_VIDEO_DEV is not set
# CONFIG_NVRAM is not set
CONFIG_JOYSTICK=y
# CONFIG_MISC_RADIO is not set

#
# Ftape, the floppy tape device driver
#
# CONFIG_FTAPE is not set

#
# Sound
#
CONFIG_SOUND=m
# CONFIG_SOUND_PAS is not set
CONFIG_SOUND_SB=m
CONFIG_SOUND_ADLIB=m
# CONFIG_SOUND_GUS is not set
CONFIG_SOUND_MPU401=m
# CONFIG_SOUND_PSS is not set
CONFIG_SOUND_MSS=m
# CONFIG_SOUND_SSCAPE is not set
# CONFIG_SOUND_TRIX is not set
# CONFIG_SOUND_MAD16 is not set
# CONFIG_MAD16_OLDCARD is not set
# CONFIG_SOUND_CS4232 is not set
# CONFIG_SOUND_MAUI is not set
# CONFIG_SGALAXY is not set
CONFIG_SOUND_OPL3SA1=m
# CONFIG_SOUND_SOFTOSS is not set
CONFIG_SOUND_YM3812=m
# CONFIG_SOUND_VMIDI is not set
# CONFIG_SOUND_UART6850 is not set

#
# Additional low level sound drivers
#
# CONFIG_LOWLEVEL_SOUND is not set

#
# Kernel hacking
#
# CONFIG_PROFILE is not set
# CONFIG_MAGIC_SYSRQ is not set
CONFIG_VGA_CONSOLE=y

i can't give you an oops-file for the 2.1.103, because i don't want to
photograph my screen and send it along here.

nevertheless i can give you an oops for 2.1.101 using the same configuration
like above:

Oops: 0000
CPU: 0
EIP: 0010:[<c011ab74>]
EFLAGS: 00010296
eax: c28f5fb4 ebx: c28f5fb4 ecx: 0000348f edx: 00001dd3
esi: 0000001e edi: 0000348f ebp: c28f5f9c esp: c28f5f60
ds: 0018 es: 0018 ss: 0018
Process syslogd (pid: 99, process nr: 9, stackpage=c28f5000)
Stack: c28f5fb4 00000000 0000348f bffff7cc c011ad9d c28f5fb4 c28f5fac c28f4000
0000000a bffff7cc c28f5fbc c0114664 00000000 c28f5fac c28f5f9c e0000000
40073a9c 00000000 00000000 00000000 00000000 0000001e 00000000 bffff684
Call Trace: [<c011ad9d>] [<c0114664>] [<c0109eb8>]
Code: 8b 48 04 81 fe 28 5c 8f 02 77 29 81 c1 0f 27 00 00 89 c8 bb

i don't know if the output of ksymoops is correct because it is using a
System.map for 2.1.102, but the oops is from 2.1.101.

Using /home/weigon/linux/System.map' to map addresses to symbols.

>>EIP: c011ab74 <do_getitimer+c0/e4>
Trace: c011ad9d <sys_setitimer+65/120>
Trace: c0114664 <timer_bh+27c/394>
Trace: c0109eb8 <signal_return+28/30>
Code: c011ab74 <do_getitimer+c0/e4>
Code: c011ab74 <do_getitimer+c0/e4> 8b 48 04 movl
0x4(%eax),%ecx
Code: c011ab77 <do_getitimer+c3/e4> 81 fe 28 5c 8f cmpl
$0x28f5c28,%esi
Code: c011ab7d <do_getitimer+c9/e4> 77 29 ja c011aba8
<sys_getitimer+10/6c>
Code: c011ab85 <do_getitimer+d1/e4> 81 c1 0f 27 00 addl $0x270f,%ecx
Code: c011ab8b <do_getitimer+d7/e4> 89 c8 movl %ecx,%eax
Code: c011ab8d <do_getitimer+d9/e4> bb 00 90 90 90 movl $0x90909000,%ebx

thats all
Jan

---
Project: GGI - S3-Vision-driver -- http://www.ggi-project.org/
-)= Jan (Weigon) Kneschke -- Kiel -- Northern Germany =(-

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.rutgers.edu