Re: compiling 2.0.20

M Shariful Anam (
Tue, 1 Oct 1996 01:31:15 +0600 (GMT+0600)

On Mon, 30 Sep 1996, Peter T. Breuer wrote:
> 2.7.0 is probably not enough. You should be at 2.7.2 in order to be

Well... the very first time I tried to compile 2.0.7 on my P5-120 laptop,
it worked like a charm. Without the slightest trouble it compiled. It had
1.2.13 and gcc 2.6.3! But now 2.7.0 is not good enough? Hmm...

> You have a screwed ld. Maybe it's configured for a.out and not elf.
> What does ld -v say? These kind of problems often come when you install
> an a.out compiler thinking it is an elf compiler, and an elf linker
> thinking it is an a.out linker, etc. (or just don't know the
> difference, or install both and one overwrites the other, ...)

I untared and gcc, libc and just put the in places, sine they didn't
have any install (except for I think). BTW, all my libs are a.out.

> No (unless of course all these machines are the same hardware :-).
> With this evidence it looks like you have a screwed gcc installation.
> But to check, try different hardware and different software, one at a
> time.

I tried this on 4 different machine, on more or less different hardware
(all were pentiums, ram 8 - 64M, HD 1G - 3G).

 M Shariful Anam                              <>

Kaifnet Services -- Bangladesh