Re: [PATCH 11/11] drm/mediatek: Rename "pending_needs_vblank" to "needs_vblank"

From: CK Hu (胡俊光)
Date: Thu Mar 14 2024 - 03:26:46 EST


Hi, Shawn:

On Mon, 2024-02-26 at 16:50 +0800, Shawn Sung wrote:
> From: Hsiao Chien Sung <shawn.sung@xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx>
>
> Rename "pending_needs_vblank" to "needs_vblank" to reduce the code
> size.

In mtk crtc, many variable has prefix 'pending' to indicate something
has not been done yet. To align this naming, I think it's better to
keep this prefix.

Regards,
CK

>
> Signed-off-by: Hsiao Chien Sung <
> shawn.sung@xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx>
> ---
> drivers/gpu/drm/mediatek/mtk_crtc.c | 8 ++++----
> 1 file changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/gpu/drm/mediatek/mtk_crtc.c
> b/drivers/gpu/drm/mediatek/mtk_crtc.c
> index 7fe234de83a3..a1fb6c67681d 100644
> --- a/drivers/gpu/drm/mediatek/mtk_crtc.c
> +++ b/drivers/gpu/drm/mediatek/mtk_crtc.c
> @@ -42,7 +42,7 @@ struct mtk_crtc {
> struct drm_crtc base;
> bool enabled;
>
> - bool pending_needs_vblank;
> + bool needs_vblank;
> struct drm_pending_vblank_event *event;
>
> struct drm_plane *planes;
> @@ -105,9 +105,9 @@ static void mtk_crtc_finish_page_flip(struct
> mtk_crtc *mtk_crtc)
> static void mtk_drm_finish_page_flip(struct mtk_crtc *mtk_crtc)
> {
> drm_crtc_handle_vblank(&mtk_crtc->base);
> - if (!mtk_crtc->config_updating && mtk_crtc-
> >pending_needs_vblank) {
> + if (!mtk_crtc->config_updating && mtk_crtc->needs_vblank) {
> mtk_crtc_finish_page_flip(mtk_crtc);
> - mtk_crtc->pending_needs_vblank = false;
> + mtk_crtc->needs_vblank = false;
> }
> }
>
> @@ -571,7 +571,7 @@ static void mtk_crtc_update_config(struct
> mtk_crtc *mtk_crtc, bool needs_vblank)
> mutex_lock(&mtk_crtc->hw_lock);
> mtk_crtc->config_updating = true;
> if (needs_vblank)
> - mtk_crtc->pending_needs_vblank = true;
> + mtk_crtc->needs_vblank = true;
>
> for (i = 0; i < mtk_crtc->layer_nr; i++) {
> struct drm_plane *plane = &mtk_crtc->planes[i];