Re: [PATCH 2/4] x86/boot: replace __PHYSICAL_START with LOAD_PHYSICAL_ADDR

From: Ingo Molnar
Date: Wed Mar 13 2024 - 06:29:43 EST



* Wei Yang <richard.weiyang@xxxxxxxxx> wrote:

> Both __PHYSICAL_START and LOAD_PHYSICAL_ADDR are defined to get aligned
> CONFIG_PHYSICAL_START, so we can replace __PHYSICAL_START with
> LOAD_PHYSICAL_ADDR. And then remove the definition of __PHYSICAL_START,
> which is only used to define __START_KERNEL.
>
> Since <asm/boot.h> includes <asm/pgtable_types.h>, which includes
> <asm/page_types.h>, it is fine to move definition from <asm/boot.h> to
> <asm/page_types.h>.
>
> Signed-off-by: Wei Yang <richard.weiyang@xxxxxxxxx>
> ---
> arch/x86/include/asm/boot.h | 5 -----
> arch/x86/include/asm/page_types.h | 8 +++++---
> 2 files changed, 5 insertions(+), 8 deletions(-)
>
> diff --git a/arch/x86/include/asm/boot.h b/arch/x86/include/asm/boot.h
> index a38cc0afc90a..12cbc57d0128 100644
> --- a/arch/x86/include/asm/boot.h
> +++ b/arch/x86/include/asm/boot.h
> @@ -6,11 +6,6 @@
> #include <asm/pgtable_types.h>
> #include <uapi/asm/boot.h>
>
> -/* Physical address where kernel should be loaded. */
> -#define LOAD_PHYSICAL_ADDR ((CONFIG_PHYSICAL_START \
> - + (CONFIG_PHYSICAL_ALIGN - 1)) \
> - & ~(CONFIG_PHYSICAL_ALIGN - 1))
> -
> /* Minimum kernel alignment, as a power of two */
> #ifdef CONFIG_X86_64
> # define MIN_KERNEL_ALIGN_LG2 PMD_SHIFT
> diff --git a/arch/x86/include/asm/page_types.h b/arch/x86/include/asm/page_types.h
> index 86bd4311daf8..acc1620fd121 100644
> --- a/arch/x86/include/asm/page_types.h
> +++ b/arch/x86/include/asm/page_types.h
> @@ -31,10 +31,12 @@
>
> #define VM_DATA_DEFAULT_FLAGS VM_DATA_FLAGS_TSK_EXEC
>
> -#define __PHYSICAL_START ALIGN(CONFIG_PHYSICAL_START, \
> - CONFIG_PHYSICAL_ALIGN)
> +/* Physical address where kernel should be loaded. */
> +#define LOAD_PHYSICAL_ADDR ((CONFIG_PHYSICAL_START \
> + + (CONFIG_PHYSICAL_ALIGN - 1)) \
> + & ~(CONFIG_PHYSICAL_ALIGN - 1))

I agree with this simplification, but the ALIGN() expression is far easier
to read, so please keep that one instead of the open-coded version.

Thanks,

Ingo