Re: [PATCH] vfio: amba: Rename pl330_ids[] to vfio_amba_ids[]

From: Alex Williamson
Date: Tue Mar 05 2024 - 18:13:29 EST


On Mon, 26 Feb 2024 12:09:26 +0100
Geert Uytterhoeven <geert+renesas@xxxxxxxxx> wrote:

> Obviously drivers/vfio/platform/vfio_amba.c started its life as a
> simplified copy of drivers/dma/pl330.c, but not all variable names were
> updated.
>
> Signed-off-by: Geert Uytterhoeven <geert+renesas@xxxxxxxxx>
> ---
> drivers/vfio/platform/vfio_amba.c | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/vfio/platform/vfio_amba.c b/drivers/vfio/platform/vfio_amba.c
> index 6464b3939ebcfb53..485c6f9161a91be0 100644
> --- a/drivers/vfio/platform/vfio_amba.c
> +++ b/drivers/vfio/platform/vfio_amba.c
> @@ -122,16 +122,16 @@ static const struct vfio_device_ops vfio_amba_ops = {
> .detach_ioas = vfio_iommufd_physical_detach_ioas,
> };
>
> -static const struct amba_id pl330_ids[] = {
> +static const struct amba_id vfio_amba_ids[] = {
> { 0, 0 },
> };
>
> -MODULE_DEVICE_TABLE(amba, pl330_ids);
> +MODULE_DEVICE_TABLE(amba, vfio_amba_ids);
>
> static struct amba_driver vfio_amba_driver = {
> .probe = vfio_amba_probe,
> .remove = vfio_amba_remove,
> - .id_table = pl330_ids,
> + .id_table = vfio_amba_ids,
> .drv = {
> .name = "vfio-amba",
> .owner = THIS_MODULE,

Applied to vfio next branch for v6.9. Thanks,

Alex