Re: [PATCH 2/4] scsi: ufs: Re-use exec_dev_cmd

From: Bart Van Assche
Date: Tue Mar 05 2024 - 14:10:11 EST


On 3/4/24 01:23, Avri Altman wrote:
+static int __exec_dev_cmd(struct ufs_hba *hba, struct ufshcd_lrb *lrbp,
+ const u32 tag, int timeout)

Please choose a better name than __exec_dev_cmd. Function names in this file should start with the ufshcd_ prefix.

@@ -3300,28 +3318,15 @@ static void ufshcd_dev_man_unlock(struct ufs_hba *hba)
static int ufshcd_exec_dev_cmd(struct ufs_hba *hba,
enum dev_cmd_type cmd_type, int timeout)
{
- DECLARE_COMPLETION_ONSTACK(wait);
const u32 tag = hba->reserved_slot;
- struct ufshcd_lrb *lrbp;
+ struct ufshcd_lrb *lrbp = &hba->lrb[tag];
int err;
- lrbp = &hba->lrb[tag];
- lrbp->cmd = NULL;
err = ufshcd_compose_dev_cmd(hba, lrbp, cmd_type, tag);

Please restore the "lrbp->cmd = NULL" assignment. I don't think that it
is safe to remove that assignment.

Thanks,

Bart.