Re: [PATCH v1 02/14] serial: core: Add UPIO_UNSET constant for unset port type

From: Florian Fainelli
Date: Wed Feb 21 2024 - 13:47:48 EST


On 2/21/24 10:31, Andy Shevchenko wrote:
In some APIs we would like to assign the special value to iotype
and compare against it in another places. Introduce UPIO_UNSET
for this purpose.

Note, we can't use 0, because it's a valid value for IO port access.

Signed-off-by: Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx>
---
include/linux/serial_core.h | 1 +
1 file changed, 1 insertion(+)

diff --git a/include/linux/serial_core.h b/include/linux/serial_core.h
index 2d2ec99eca93..2b0526ae1fac 100644
--- a/include/linux/serial_core.h
+++ b/include/linux/serial_core.h
@@ -470,6 +470,7 @@ struct uart_port {
unsigned char iotype; /* io access style */
+#define UPIO_UNSET ((unsigned char)~0U) /* UCHAR_MAX */

Nit: I would name this UPIO_UNKNOWN, or UPIO_NOTSET, unset means to me that it was previously set and we undid that action, whereas unknown or not set means we never did.
--
Florian