Re: [PATCH] irqchip/bcm-6345-l1: Prefer struct_size over open coded arithmetic

From: Florian Fainelli
Date: Fri Feb 09 2024 - 20:20:12 EST

On 2/9/2024 10:16 AM, Erick Archer wrote:
This is an effort to get rid of all multiplications from allocation
functions in order to prevent integer overflows [1].

As the cpu variable is a pointer to "struct bcm6345_l1_cpu" and this
structure ends in a flexible array:

struct bcm6345_l1_cpu {
u32 enable_cache[];

the preferred way in the kernel is to use the struct_size() helper to
do the arithmetic instead of the argument "size + count * size" in the
kzalloc() function.

This way, the code is more readable and more safer.

Link: [1]
Link: [2]
Signed-off-by: Erick Archer <erick.archer@xxxxxxx>

Reviewed-by: Florian Fainelli <florian.fainelli@xxxxxxxxxxxx>

Attachment: smime.p7s
Description: S/MIME Cryptographic Signature