[PATCH 01/20] mm: zswap: rename zswap_free_entry to zswap_entry_free

From: Johannes Weiner
Date: Mon Jan 29 2024 - 20:42:31 EST


There is a zswap_entry_ namespace with multiple functions already.

Signed-off-by: Johannes Weiner <hannes@xxxxxxxxxxx>
---
mm/zswap.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/mm/zswap.c b/mm/zswap.c
index 7f88b3a77e4a..173f2e6657de 100644
--- a/mm/zswap.c
+++ b/mm/zswap.c
@@ -520,7 +520,7 @@ static struct zpool *zswap_find_zpool(struct zswap_entry *entry)
* Carries out the common pattern of freeing and entry's zpool allocation,
* freeing the entry itself, and decrementing the number of stored pages.
*/
-static void zswap_free_entry(struct zswap_entry *entry)
+static void zswap_entry_free(struct zswap_entry *entry)
{
if (!entry->length)
atomic_dec(&zswap_same_filled_pages);
@@ -555,7 +555,7 @@ static void zswap_entry_put(struct zswap_entry *entry)
WARN_ON_ONCE(refcount < 0);
if (refcount == 0) {
WARN_ON_ONCE(!RB_EMPTY_NODE(&entry->rbnode));
- zswap_free_entry(entry);
+ zswap_entry_free(entry);
}
}

--
2.43.0