Re: [PATCH v1 1/1] wq: Avoid using isolated cpus' timers on unbounded queue_delayed_work

From: Leonardo Bras
Date: Mon Jan 29 2024 - 16:17:38 EST


On Mon, Jan 29, 2024 at 05:54:04PM -0300, Leonardo Bras wrote:
> On Mon, Jan 29, 2024 at 10:51:09AM -1000, Tejun Heo wrote:
> > On Mon, Jan 29, 2024 at 04:26:57PM -0300, Leonardo Bras wrote:
> > > > Isn't that still the same number of add_timer[_on]() calls?
> > >
> > > Yeah, sorry about this, what I meant was: If we are ok on calling
> > > add_timer_on() multiple times, I would rather go with the above version, as
> > > I think it's better for readability.
> >
> > I don't know. It looks more verbose and less clear to me in that it isn't
> > immediately clear that every branch ends with timer being added. But this is
> > really minor, so unless you have a really strong opinion against the
> > suggested structured, can we just do that?
>
> Sure, we can go with the one you suggested.

Hello Tejun,

While I was reworking the code with your suggestion, I found out
that there is a difference in our suggestions:

###
if (housekeeping_enabled(HK_TYPE_TIMER)) {
cpu = smp_processor_id();
if (!housekeeping_test_cpu(cpu, HK_TYPE_TIMER))
cpu = housekeeping_any_cpu(HK_TYPE_TIMER);
add_timer_on(timer, cpu);
} else {
if (likely(cpu == WORK_CPU_UNBOUND))
add_timer(timer, cpu);
else
add_timer_on(timer, cpu);
}
###

In your suggestion you always check housekeeping to be sure that the timer
is never handled on an isolated cpu.

In my suggestions, it only checks and use housekeeping cpus only
if (cpu == WORK_CPU_UNBOUND).

I was previously afraid to use the approach of your suggestion due to some
user having the need to handle the timer on the cpu passed as parameter.

But now thinking on it again, it does make sense that the CPU which handles
the timer has nothing to do with the one that actually runs the work
(other than possible cacheline optimizations), and your suggestion is much
better for CPU Isolation than mine.

I will send the v2 soon.

Thanks again,
Leo

>
> Thanks!
> Leo
>
> >
> > Thanks.
> >
> > --
> > tejun
> >