Re: [PATCH v3 17/17] spi: s3c64xx: use bitfield access macros

From: Tudor Ambarus
Date: Mon Jan 29 2024 - 12:59:51 EST




On 1/29/24 16:42, Mark Brown wrote:
> On Sat, Jan 27, 2024 at 03:44:24AM +0000, Tudor Ambarus wrote:
>> On 1/27/24 03:38, Sam Protsenko wrote:
>
>>>>>> - val |= S3C64XX_SPI_MODE_BUS_TSZ_HALFWORD;
>>>>>> - val |= S3C64XX_SPI_MODE_CH_TSZ_HALFWORD;
>>>>>> + val |= FIELD_PREP(S3C64XX_SPI_MODE_BUS_TSZ_MASK,
>>>>>> + S3C64XX_SPI_MODE_BUS_TSZ_HALFWORD) |
>>>>>> + FIELD_PREP(S3C64XX_SPI_MODE_CH_TSZ_MASK,
>>>>>> + S3C64XX_SPI_MODE_CH_TSZ_HALFWORD);
>
>>>>> Two people complained it makes the code harder to read. Yet it's not
>>>>> addressed in v3. Please see my comments for your previous submission
>>>>> explaining what can be done, and also Andi's comment on that matter.
>
>>>> I kept these intentionally. Please read my reply on that matter or the
>>>> cover letter to this patch set.
>
>>> I read it. But still don't like it 🙂 I'm sure it's possible to do
>>> this modification, but at the same time keep the code clean an easy to
>>> read. The code above -- I don't like at all, sorry. It was much better
>>> before this patch, IMHO.
>
>> Yeah, I guess Mark will tip the scale.
>
> All other things being equal I tend to try not to get too involved with
> minor coding style stuff in drivers. People do seem to like
> FIELD_PREP() but I have a hard time getting *too* excited.

Ok, I'll remove FIELD_PREP. Would you please consider the other patches,
all are simple. There's another "controversy" on 6/17. You can ignore
that as well maybe, and I'll resend it where I refrain myself to just
removing the cast.