Re: [PATCH v2 07/10] clk: qcom: Add dispcc clock driver for x1e80100

From: Bryan O'Donoghue
Date: Fri Dec 15 2023 - 07:45:32 EST


On 14/12/2023 16:49, Abel Vesa wrote:
From: Rajendra Nayak <quic_rjendra@xxxxxxxxxxx>

Add the dispcc clock driver for x1e80100.

Signed-off-by: Rajendra Nayak <quic_rjendra@xxxxxxxxxxx>
Reviewed-by: Dmitry Baryshkov <dmitry.baryshkov@xxxxxxxxxx>
Signed-off-by: Abel Vesa <abel.vesa@xxxxxxxxxx>
---

+static struct platform_driver disp_cc_x1e80100_driver = {
+ .probe = disp_cc_x1e80100_probe,
+ .driver = {
+ .name = "disp_cc-x1e80100",
+ .of_match_table = disp_cc_x1e80100_match_table,
+ },
+};
+
+static int __init disp_cc_x1e80100_init(void)
+{
+ return platform_driver_register(&disp_cc_x1e80100_driver);
+}
+subsys_initcall(disp_cc_x1e80100_init);
+
+static void __exit disp_cc_x1e80100_exit(void)
+{
+ platform_driver_unregister(&disp_cc_x1e80100_driver);
+}
+module_exit(disp_cc_x1e80100_exit);
+
+MODULE_DESCRIPTION("QTI DISPCC X1E80100 Driver");
+MODULE_LICENSE("GPL");


And we don't even do the odd underscore insertion consistently. For whatever reason "DISPCC" instead of "DISP_CC"

Just to reiterate the underscores should be dropped from these clock controller names and defines entirely, they just eat up bytes in databases.

.name = "dispcc-x1e80100"

("QTI DISPCC X1E80100 Driver"); better but IMO we could just a complete word here

"Display Clock Controller" there's no need to abbreviate.

---
bod