Re: [PATCH v2 7/7] rust: file: add abstraction for `poll_table`

From: Alice Ryhl
Date: Wed Dec 13 2023 - 06:02:53 EST


Benno Lossin <benno.lossin@xxxxxxxxx> writes:
>>>> +#[pinned_drop]
>>>> +impl PinnedDrop for PollCondVar {
>>>> + fn drop(self: Pin<&mut Self>) {
>>>> + // Clear anything registered using `register_wait`.
>>>> + //
>>>> + // SAFETY: The pointer points at a valid wait list.
>>>
>>> I was a bit confused by "wait list", since the C type is named
>>> `wait_queue_head`, maybe just use the type name?
>>
>> I will update all instances of "wait list" to "wait_queue_head". It's
>> because I incorrectly remembered the C type name to be "wait_list".
>
> Maybe we should also change the name of the field on `CondVar`?
>
> If you guys agree, I can open a good-first-issue, since it is a very
> simple change.

I think that change is fine, but let's not add it to this patchset,
since it would need to be an eight patch. I'll let you open an issue for
it.

Alice