Re: [PATCH net-next v2 1/7] net/smc: Rename some variable 'fce' to 'fce_v2x' for clarity

From: Wen Gu
Date: Thu Nov 30 2023 - 06:02:15 EST




On 2023/11/29 20:50, Wenjia Zhang wrote:


On 24.11.23 15:42, Wen Gu wrote:
Rename some smc_clc_first_contact_ext_v2x type variables to 'fce_v2x'
to distinguish them from smc_clc_first_contact_ext type variables.

Signed-off-by: Wen Gu <guwen@xxxxxxxxxxxxxxxxx>
---
  net/smc/smc_clc.c | 26 +++++++++++++-------------
  1 file changed, 13 insertions(+), 13 deletions(-)

diff --git a/net/smc/smc_clc.c b/net/smc/smc_clc.c
index 0fda515..c41a249 100644
--- a/net/smc/smc_clc.c
+++ b/net/smc/smc_clc.c
@@ -418,15 +418,15 @@ static bool smc_clc_msg_prop_valid(struct smc_clc_msg_proposal *pclc)
      return true;
  }
-static int smc_clc_fill_fce(struct smc_clc_first_contact_ext_v2x *fce,
+static int smc_clc_fill_fce(struct smc_clc_first_contact_ext_v2x *fce_v2x,
                  struct smc_init_info *ini)

Since this function is only used by v2.x, IMO, this function name could also be changed to e.g. smc_clc_fill_fce_v2x.

Thank you, Wenjia. The function name will also be changed.