Re: [PATCH v11 02/13] dt-bindings: usb: Add bindings for multiport properties on DWC3 controller

From: Krishna Kurapati PSSNV
Date: Sat Nov 11 2023 - 08:20:08 EST




On 11/11/2023 4:25 PM, Johan Hovold wrote:
On Sat, Nov 11, 2023 at 03:17:40PM +0530, Krishna Kurapati PSSNV wrote:
On 11/11/2023 2:00 PM, Krishna Kurapati PSSNV wrote:
On 11/10/2023 6:58 PM, Johan Hovold wrote:

    phy-names:
      minItems: 1
-    maxItems: 2
-    items:
-      enum:
-        - usb2-phy
-        - usb3-phy
+    maxItems: 8
+    oneOf:
+      - items:
+          enum: [ usb2-phy, usb3-phy ]
+      - items:
+          pattern: "^usb[23]-port[0-3]$"

Shouldn't this just be

    pattern: "^usb[23]-[0-3]$"

so that it matches the names that are used by the nvidia bindings?

We already have some inconsistency in that Amlogic uses a variant based
on the legacy names that needlessly includes "phy" in the names:

    const: usb2-phy0
    const: usb2-phy1
    const: usb3-phy0
    ...

I don't think we should be introducing a third naming scheme here so I
suggest just following the nvidia bindings.

In that case, why don't we use  "^usb[23]-phy[0-3]$". I think its close
to what we have on dwc3 core already today (usb2-phy/usb3-phy).

I mean, it isn't needless. It is a phy and shouldn't the binding suggest
that and include "-phy" in the name ?

No, adding a '-phy' suffix to each name is unnecessary since the
property is called 'phy-names'.

This is also documented:

For names used in {clock,dma,interrupt,reset}-names, do not add
any suffix, e.g.: "tx" instead of "txirq" (for interrupt).

https://docs.kernel.org/devicetree/bindings/writing-bindings.html


Thanks for the explanation.

and we've already discussed this when I asked you to drop the likewise
redundant '_irq' suffix from the interrupt names.

Yes, we did discuss this in irq context. But in this case I thought it was fine because we already have usb(2/3)-"phy" already present.

When pushing v14, will make this change to usb(2/3)-(0-3) and skip port/phy.

Regards,
Krishna,