Re: [PATCH v7 09/24] x86/resctrl: Use __set_bit()/__clear_bit() instead of open coding

From: Reinette Chatre
Date: Thu Nov 09 2023 - 12:44:38 EST


Hi James,

On 10/25/2023 11:03 AM, James Morse wrote:
> The resctrl CLOSID allocator uses a single 32bit word to track which
> CLOSID are free. The setting and clearing of bits is open coded.
>
> A subsequent patch adds closid_allocated(), which adds more open

(Note use of "A subsequent patch ")

> coded bitmaps operations. These will eventually need changing to use
> the bitops helpers so that a CLOSID bitmap of the correct size can be
> allocated dynamically.
>
> Convert the existing open coded bit manipulations of closid_free_map
> to use __set_bit() and friends. These don't need to be atomic as this
> list is protected by the mutex.
>
> Tested-by: Shaopeng Tan <tan.shaopeng@xxxxxxxxxxx>
> Tested-by: Peter Newman <peternewman@xxxxxxxxxx>
> Reviewed-by: Shaopeng Tan <tan.shaopeng@xxxxxxxxxxx>
> Signed-off-by: James Morse <james.morse@xxxxxxx>
>
> ---
> Changes since v6:
> * Use the __ inatomic helpers and add lockdep_assert_held() annotations to
> document how this is safe.
> * Fixed a resctrl_closid_is_free()/closid_allocated() rename in the commit
> message.
> * Use RESCTRL_RESERVED_CLOSID to improve readability.
> ---
> arch/x86/kernel/cpu/resctrl/rdtgroup.c | 16 +++++++++++-----
> 1 file changed, 11 insertions(+), 5 deletions(-)
>
> diff --git a/arch/x86/kernel/cpu/resctrl/rdtgroup.c b/arch/x86/kernel/cpu/resctrl/rdtgroup.c
> index 9864cb49d58c..f6051a3e7262 100644
> --- a/arch/x86/kernel/cpu/resctrl/rdtgroup.c
> +++ b/arch/x86/kernel/cpu/resctrl/rdtgroup.c
> @@ -111,7 +111,7 @@ void rdt_staged_configs_clear(void)
> * - Our choices on how to configure each resource become progressively more
> * limited as the number of resources grows.
> */
> -static int closid_free_map;
> +static unsigned long closid_free_map;
> static int closid_free_map_len;
>
> int closids_supported(void)
> @@ -131,7 +131,7 @@ static void closid_init(void)
> closid_free_map = BIT_MASK(rdt_min_closid) - 1;
>
> /* CLOSID 0 is always reserved for the default group */

Seems appropriate for the comment to be updated to the new define also.

With that addressed you can add:
Reviewed-by: Reinette Chatre <reinette.chatre@xxxxxxxxx>

Reinette