Re: [PATCH 05/24] selftests/resctrl: Create cache_size() helper

From: Ilpo Järvinen
Date: Fri Nov 03 2023 - 04:54:07 EST


On Thu, 2 Nov 2023, Reinette Chatre wrote:

> Hi Ilpo,
>
> On 10/24/2023 2:26 AM, Ilpo Järvinen wrote:
> > CAT and CMT tests calculate the span size from the n-bits cache
> > allocation on their own.
> >
> > Add cache_size() helper which calculates size of the cache portion for
> > the given number of bits and use it to replace the existing span
> > calculations. This also prepares for the new CAT test that will need to
> > determine the size of the cache portion also during results processing.
> >
> > cache_size local variables were renamed out of the way to
> > cache_total_size.
>
> Please do stick to imperative mood ... "Rename cache_size local
> variables ..."
>
>
> ...
>
> > diff --git a/tools/testing/selftests/resctrl/resctrl.h b/tools/testing/selftests/resctrl/resctrl.h
> > index 2f3f0ee439d8..da06b2d492f9 100644
> > --- a/tools/testing/selftests/resctrl/resctrl.h
> > +++ b/tools/testing/selftests/resctrl/resctrl.h
> > @@ -117,4 +117,18 @@ int show_cache_info(unsigned long sum_llc_val, int no_of_bits,
> > unsigned long max_diff_percent, unsigned long num_of_runs,
> > bool platform, bool cmt);
> >
> > +/*
> > + * cache_size - Calculate the size of a cache portion
> > + * @cache_size: Cache size in bytes
> > + * @mask: Cache portion mask
> > + * @cache_mask: Full bitmask for the cache
> > + *
> > + * Return: The size of the cache portion in bytes.
> > + */
> > +static inline int cache_size(unsigned long cache_size, unsigned long mask,
> > + unsigned long cache_mask)
> > +{
> > + return cache_size * count_bits(mask) / count_bits(cache_mask);
> > +}
> > +
> > #endif /* RESCTRL_H */
>
>
> The get_cache_size() and cache_size() naming appears similar enough to me
> to cause confusion. Considering the "portion" term above, what do you think
> of "cache_portion_size()" or even "cache_portion_bytes()"?

Yes, I'm more than happy to rename them. This naming was what you
suggested earlier. (I used cache_alloc_size() or something like that
initially and you were against using "alloc" in the name.)

--
i.