Re: [PATCH v2 1/5] Staging: sm750fb: Rename displayControlAdjust_SM750E

From: Dorcas Litunya
Date: Tue Oct 17 2023 - 04:28:17 EST


On Tue, Oct 17, 2023 at 09:50:50AM +0200, Greg Kroah-Hartman wrote:
> On Mon, Oct 16, 2023 at 11:14:08PM +0300, Dorcas AnonoLitunya wrote:
> > Rename function displayControlAdjust_SM750E to
> > display_control_adjust_SM750E. This follows snakecase naming convention
> > and ensures a consistent naming style throughout the file. Issue found by
> > checkpatch.
> >
> > Mutes the following error:
> > CHECK:Avoid CamelCase: <displayControlAdjust_SM750E>
> >
> > Signed-off-by: Dorcas AnonoLitunya <anonolitunya@xxxxxxxxx>
> > ---
> > drivers/staging/sm750fb/ddk750_mode.c | 6 +++---
> > 1 file changed, 3 insertions(+), 3 deletions(-)
> >
> > diff --git a/drivers/staging/sm750fb/ddk750_mode.c b/drivers/staging/sm750fb/ddk750_mode.c
> > index e00a6cb31947..8708995f676c 100644
> > --- a/drivers/staging/sm750fb/ddk750_mode.c
> > +++ b/drivers/staging/sm750fb/ddk750_mode.c
> > @@ -14,8 +14,8 @@
> > * in bit 29:27 of Display Control register.
> > */
> > static unsigned long
> > -displayControlAdjust_SM750LE(struct mode_parameter *pModeParam,
> > - unsigned long dispControl)
> > +display_control_adjust_SM750LE(struct mode_parameter *pModeParam,
> > + unsigned long dispControl)
> > {
> > unsigned long x, y;
> >
> > @@ -125,7 +125,7 @@ static int programModeRegisters(struct mode_parameter *pModeParam,
> > tmp |= DISPLAY_CTRL_HSYNC_PHASE;
> >
> > if (sm750_get_chip_type() == SM750LE) {
> > - displayControlAdjust_SM750LE(pModeParam, tmp);
> > + display_control_adjust_SM750LE(pModeParam, tmp);
>
> Why is this function returning a value if it is just being ignored?
>
> It's not the issue here in the patch, but for future changes.
>
Hi Greg,

I will do the correction in the next patchset to correct both functions
return value as this patchset was not focused on that. Does this mean
that this patchset has been accepted? Or should I submit another
patchset that includes the two changes suggested on function return
values?

thanks,

Dorcas
> thanks,
>
> greg k-h