Re: [PATCH v1 1/9] ACPI: bus: Make notify wrappers more generic

From: Wilczynski, Michal
Date: Thu Oct 05 2023 - 12:07:34 EST




On 10/5/2023 12:57 PM, Rafael J. Wysocki wrote:
> On Thu, Oct 5, 2023 at 10:10 AM Wilczynski, Michal
> <michal.wilczynski@xxxxxxxxx> wrote:
>> Hi,
>>
>> Thanks for your review !
>>
>> On 10/4/2023 9:09 PM, Rafael J. Wysocki wrote:
>>> On Mon, Sep 25, 2023 at 6:31 PM Michal Wilczynski
>>> <michal.wilczynski@xxxxxxxxx> wrote:
>>>> acpi_dev_install_notify_handler() and acpi_dev_remove_notify_handler()
>>>> are wrappers around ACPICA installers. They are meant to save some
>>>> duplicated code from drivers. However as we're moving towards drivers
>>>> operating on platform_device they become a bit inconvenient to use as
>>>> inside the driver code we mostly want to use driver data of platform
>>>> device instead of ACPI device.
>>> That's fair enough, but ->
>>>
>>>> Make notify handlers installer wrappers more generic, while still
>>>> saving some code that would be duplicated otherwise.
>>>>
>>>> Reviewed-by: Andy Shevchenko <andy.shevchenko@xxxxxxxxx>
>>>> Signed-off-by: Michal Wilczynski <michal.wilczynski@xxxxxxxxx>
>>>> ---
>>>>
>>>> Notes:
>>>> So one solution could be to just replace acpi_device with
>>>> platform_device as an argument in those functions. However I don't
>>>> believe this is a correct solution, as it is very often the case that
>>>> drivers declare their own private structures which gets allocated during
>>>> the .probe() callback, and become the heart of the driver. When drivers
>>>> do that it makes much more sense to just pass the private structure
>>>> to the notify handler instead of forcing user to dance with the
>>>> platform_device or acpi_device.
>>>>
>>>> drivers/acpi/ac.c | 6 +++---
>>>> drivers/acpi/acpi_video.c | 6 +++---
>>>> drivers/acpi/battery.c | 6 +++---
>>>> drivers/acpi/bus.c | 14 ++++++--------
>>>> drivers/acpi/hed.c | 6 +++---
>>>> drivers/acpi/nfit/core.c | 6 +++---
>>>> drivers/acpi/thermal.c | 6 +++---
>>>> include/acpi/acpi_bus.h | 9 ++++-----
>>>> 8 files changed, 28 insertions(+), 31 deletions(-)
>>>>
>>>> diff --git a/drivers/acpi/ac.c b/drivers/acpi/ac.c
>>>> index 225dc6818751..0b245f9f7ec8 100644
>>>> --- a/drivers/acpi/ac.c
>>>> +++ b/drivers/acpi/ac.c
>>>> @@ -256,8 +256,8 @@ static int acpi_ac_add(struct acpi_device *device)
>>>> ac->battery_nb.notifier_call = acpi_ac_battery_notify;
>>>> register_acpi_notifier(&ac->battery_nb);
>>>>
>>>> - result = acpi_dev_install_notify_handler(device, ACPI_ALL_NOTIFY,
>>>> - acpi_ac_notify);
>>>> + result = acpi_dev_install_notify_handler(device->handle, ACPI_ALL_NOTIFY,
>>>> + acpi_ac_notify, device);
>>>> if (result)
>>>> goto err_unregister;
>>>>
>>>> @@ -306,7 +306,7 @@ static void acpi_ac_remove(struct acpi_device *device)
>>>>
>>>> ac = acpi_driver_data(device);
>>>>
>>>> - acpi_dev_remove_notify_handler(device, ACPI_ALL_NOTIFY,
>>>> + acpi_dev_remove_notify_handler(device->handle, ACPI_ALL_NOTIFY,
>>>> acpi_ac_notify);
>>>> power_supply_unregister(ac->charger);
>>>> unregister_acpi_notifier(&ac->battery_nb);
>>>> diff --git a/drivers/acpi/acpi_video.c b/drivers/acpi/acpi_video.c
>>>> index 948e31f7ce6e..025c17890127 100644
>>>> --- a/drivers/acpi/acpi_video.c
>>>> +++ b/drivers/acpi/acpi_video.c
>>>> @@ -2059,8 +2059,8 @@ static int acpi_video_bus_add(struct acpi_device *device)
>>>>
>>>> acpi_video_bus_add_notify_handler(video);
>>>>
>>>> - error = acpi_dev_install_notify_handler(device, ACPI_DEVICE_NOTIFY,
>>>> - acpi_video_bus_notify);
>>>> + error = acpi_dev_install_notify_handler(device->handle, ACPI_DEVICE_NOTIFY,
>>>> + acpi_video_bus_notify, device);
>>>> if (error)
>>>> goto err_remove;
>>>>
>>>> @@ -2092,7 +2092,7 @@ static void acpi_video_bus_remove(struct acpi_device *device)
>>>>
>>>> video = acpi_driver_data(device);
>>>>
>>>> - acpi_dev_remove_notify_handler(device, ACPI_DEVICE_NOTIFY,
>>>> + acpi_dev_remove_notify_handler(device->handle, ACPI_DEVICE_NOTIFY,
>>>> acpi_video_bus_notify);
>>>>
>>>> mutex_lock(&video_list_lock);
>>>> diff --git a/drivers/acpi/battery.c b/drivers/acpi/battery.c
>>>> index 969bf81e8d54..45dae32a8646 100644
>>>> --- a/drivers/acpi/battery.c
>>>> +++ b/drivers/acpi/battery.c
>>>> @@ -1213,8 +1213,8 @@ static int acpi_battery_add(struct acpi_device *device)
>>>>
>>>> device_init_wakeup(&device->dev, 1);
>>>>
>>>> - result = acpi_dev_install_notify_handler(device, ACPI_ALL_NOTIFY,
>>>> - acpi_battery_notify);
>>>> + result = acpi_dev_install_notify_handler(device->handle, ACPI_ALL_NOTIFY,
>>>> + acpi_battery_notify, device);
>>>> if (result)
>>>> goto fail_pm;
>>>>
>>>> @@ -1241,7 +1241,7 @@ static void acpi_battery_remove(struct acpi_device *device)
>>>>
>>>> battery = acpi_driver_data(device);
>>>>
>>>> - acpi_dev_remove_notify_handler(device, ACPI_ALL_NOTIFY,
>>>> + acpi_dev_remove_notify_handler(device->handle, ACPI_ALL_NOTIFY,
>>>> acpi_battery_notify);
>>>>
>>>> device_init_wakeup(&device->dev, 0);
>>>> diff --git a/drivers/acpi/bus.c b/drivers/acpi/bus.c
>>>> index f41dda2d3493..479fe888d629 100644
>>>> --- a/drivers/acpi/bus.c
>>>> +++ b/drivers/acpi/bus.c
>>>> @@ -554,14 +554,13 @@ static void acpi_device_remove_notify_handler(struct acpi_device *device,
>>>> acpi_os_wait_events_complete();
>>>> }
>>>>
>>>> -int acpi_dev_install_notify_handler(struct acpi_device *adev,
>>>> - u32 handler_type,
>>>> - acpi_notify_handler handler)
>>>> +int acpi_dev_install_notify_handler(acpi_handle handle, u32 handler_type,
>>>> + acpi_notify_handler handler, void *context)
>>>> {
>>>> acpi_status status;
>>>>
>>>> - status = acpi_install_notify_handler(adev->handle, handler_type,
>>>> - handler, adev);
>>>> + status = acpi_install_notify_handler(handle, handler_type,
>>>> + handler, context);
>>> The wrapper now takes exactly the same arguments as the wrapped
>>> function, so what exactly is the point of having it? The return value
>>> type?
>> I considered removing the wrapper altogether, but decided not to do so.
>> One trivial advantage of leaving this wrapper is the return value type as
>> you noticed, another is that the removal wrapper actually does something
>> extra and removing it would result in duplicate code among the drivers.
>> So I didn't really want to remove the 'install' wrapper but leave the
>> 'remove' wrapper, as I think this might be confusing for the future reader.
>> In my mind if something is removed by the wrapper it should also be
>> installed by the wrapper.
> I agree here.
>
>>>> if (ACPI_FAILURE(status))
>>>> return -ENODEV;
>>>>
>>>> @@ -569,11 +568,10 @@ int acpi_dev_install_notify_handler(struct acpi_device *adev,
>>>> }
>>>> EXPORT_SYMBOL_GPL(acpi_dev_install_notify_handler);
>>>>
>>>> -void acpi_dev_remove_notify_handler(struct acpi_device *adev,
>>>> - u32 handler_type,
>>>> +void acpi_dev_remove_notify_handler(acpi_handle handle, u32 handler_type,
>>>> acpi_notify_handler handler)
>>>> {
>>>> - acpi_remove_notify_handler(adev->handle, handler_type, handler);
>>>> + acpi_remove_notify_handler(handle, handler_type, handler);
>>>> acpi_os_wait_events_complete();
>>> Here at least there is the extra workqueues synchronization point.
>>>
>>> That said, why exactly is it better to use acpi_handle instead of a
>>> struct acpi_device pointer?
>> I wanted to make the wrapper as close as possible to the wrapped function.
>> This way it would be easier to remove it in the future i.e if we ever deem
>> extra synchronization not worth it etc. What the ACPICA function need to
>> install a wrapper is a handle not a pointer to a device.
>> So there is no need for a middle man.
> Taking a struct acpi_device pointer as the first argument is part of
> duplication reduction, however, because in the most common case it
> saves the users of it the need to dereference the struct acpi_device
> they get from ACPI_COMPANION() in order to obtain the handle.

User don't even have to use acpi device anywhere, as he can choose
to use ACPI_HANDLE() instead on 'struct device*' and never interact
with acpi device directly.

>
> Arguably, acpi_handle is an ACPICA concept and it is better to reduce
> its usage outside ACPICA.

Use of acpi_handle is deeply entrenched in the kernel. There is even
a macro ACPI_HANDLE() that returns acpi_handle. I would say it's
way too late to limit it to ACPICA internal code.

>
>>> Realistically, in a platform driver you'll need the latter to obtain
>>> the former anyway.
>> I don't want to introduce arbitrary limitations where they are not necessary.
> I'm not sure what you mean. This patch is changing existing functions.

That's true, but those functions aren't yet deeply entrenched in the
kernel yet, so in my view how they should look like should still be
a subject for discussion, as for now they're only used locally in
drivers/acpi, and my next patchset, that would remove .notify in
platform directory would spread them more, and would
make them harder to change. For now we can change how they
work pretty painlessly.

>
>> It is often the case that driver allocates it's own private struct using kmalloc
>> family of functions, and that structure already contains everything that is
>> needed to remove the handler, so why force ? There are already examples
>> in the drivers that do that i.e in acpi_video the function
>> acpi_video_dev_add_notify_handler() uses raw ACPICA handler to install
>> a notify handler and it passes private structure there.
>> So there is value in leaving the choice of an actual type to the user of the
>> API.
> No, if the user has a pointer to struct acpi_device already, there is
> no difference between passing this and passing the acpi_handle from it
> except for the extra dereference in the latter case.

Dereference would happen anyway in the wrapper, and it doesn't cause
any harm anyway for readability in my opinion. And of course you don't
have to use acpi device at all, you can use ACPI_HANDLE() macro.

>
> If the user doesn't have a struct acpi_device pointer, let them use
> the raw ACPICA handler directly and worry about the synchronization
> themselves.

As mentioned acpi_device pointer is not really required to use the wrapper.
Instead we can use ACPI_HANDLE() macro directly. Look at the usage of
the wrapper in the AC driver [1].

-static void acpi_ac_remove(struct acpi_device *device)
+static void acpi_ac_remove(struct platform_device *pdev)
 {
-       struct acpi_ac *ac = acpi_driver_data(device);
+      struct acpi_ac *ac = platform_get_drvdata(pdev);

-       acpi_dev_remove_notify_handler(device->handle, ACPI_ALL_NOTIFY,
+       acpi_dev_remove_notify_handler(ACPI_HANDLE(ac->dev),
+                                                                     ACPI_ALL_NOTIFY,
                                                                       acpi_ac_notify);



[1] - https://lore.kernel.org/all/20230925144842.586829-1-michal.wilczynski@xxxxxxxxx/T/#mff1e8ce1e548b3252d896b56d3be0b1028b7402e

>
> The wrappers are there to cover the most common case, not to cover all cases.

In general all drivers that I'm modifying would benefit from not using direct ACPICA
installers/removers by saving that extra synchronization code that would need to be
provided otherwise, and not having to deal with acpi_status codes.

>
>> To summarize:
>> I would say the wrappers are mostly unnecessary, but they actually save
>> some duplicate code in the drivers, so I decided to leave them, as I don't
>> want to introduce duplicate code if I can avoid that.
> What duplicate code do you mean, exactly?

I would need to declare extra acpi_status variable and use ACPI_FAILURE macro
in each usage of the direct ACPICA installer. Also I would need to call
acpi_os_wait_events_complete() after calling each direct remove.

>
> IMV you haven't really explained why this particular patch is
> necessary or even useful.

Maybe using an example would better illustrate my point.
Consider using NFIT driver modification later in this series as an example:

1) With old wrapper it would look:

 static void acpi_nfit_notify(acpi_handle handle, u32 event, void *data)
{
    struct acpi_device *adev = data;
    /* Now we need to figure how to get a 'struct device*' from an acpi_device.
         Mind this we can't just do &adev->dev, as we're not using that device anymore.
         We need to get a struct device that's embedded in the platform_device that the
         driver was instantiated with.
         Not sure how it would look like, but it would require are least one extra line here.
     */
    device_lock(dev);
    __acpi_nfit_notify(dev, handle, event);
    device_unlock(dev);
}

2) With new wrapper:

static void acpi_nfit_notify(acpi_handle handle, u32 event, void *data)
{
    struct device *dev = data;

    device_lock(dev);
    __acpi_nfit_notify(dev, handle, event);
    device_unlock(dev);
}


So essentially arbitrarily forcing user to use wrapper that takes acpi device
as an argument may unnecessarily increase drivers complexity, and if we
can help with then we should. That's why this commit exists.

>
> Thanks!

Thank you :-)