Re: [PATCH] drm/ssd130x: Drop _helper prefix from struct drm_*_helper_funcs callbacks

From: Maxime Ripard
Date: Thu Sep 21 2023 - 19:20:25 EST


On Thu, Sep 21, 2023 at 10:46:05AM +0200, Geert Uytterhoeven wrote:
> On Thu, Sep 21, 2023 at 10:12 AM Maxime Ripard <mripard@xxxxxxxxxx> wrote:
> > On Thu, Sep 21, 2023 at 09:57:22AM +0200, Geert Uytterhoeven wrote:
> > > On Thu, Sep 21, 2023 at 9:44 AM Maxime Ripard <mripard@xxxxxxxxxx> wrote:
> > > > On Mon, Sep 18, 2023 at 09:19:07AM +0200, Javier Martinez Canillas wrote:
> > > > > Thomas Zimmermann <tzimmermann@xxxxxxx> writes:
> > > > > > Am 14.09.23 um 21:51 schrieb Javier Martinez Canillas:
> > > > > >> The driver uses a naming convention where functions for struct drm_*_funcs
> > > > > >> callbacks are named ssd130x_$object_$operation, while the callbacks for
> > > > > >> struct drm_*_helper_funcs are named ssd130x_$object_helper_$operation.
> > > > > >>
> > > > > >> The idea is that this helper_ prefix in the function names denote that are
> > > > > >> for struct drm_*_helper_funcs callbacks. This convention was copied from
> > > > > >> other drivers, when ssd130x was written but Maxime pointed out that is the
> > > > > >> exception rather than the norm.
> > > > > >
> > > > > > I guess you found this in my code. I want to point out that I use the
> > > > > > _helper infix to signal that these are callback for
> > > > > > drm_primary_plane_helper_funcs and *not* drm_primary_plane_funcs. The
> > > > > > naming is intentional.
> > > > >
> > > > > Yes, that's what tried to say in the commit message and indeed I got the
> > > > > convention from drivers in drivers/gpu/drm/tiny. In fact I believe these
> > > > > function names are since first iteration of the driver, when was meant to
> > > > > be a tiny driver.
> > > > >
> > > > > According to Maxime it's the exception rather than the rule and suggested
> > > > > to change it, I don't really have a strong opinion on either naming TBH.
> > > >
> > > > Maybe that's just me, but the helper in the name indeed throws me off. In my
> > > > mind, it's supposed to be used only for helpers, not functions implementing the
> > > > helpers hooks.
> > >
> > > With several callbacks using the same (field) name, it is very helpful
> > > to name the actual implementation by combining the struct type name
> > > and the field name.
> >
> > I can't think of any (at least for a given object). Which one do you have in
> > mind?
>
> E.g. atomic_check():
>
> drm_crtc_helper_funcs.atomic_check()
> drm_encoder_helper_funcs.atomic_check()
> drm_connector_helper_funcs.atomic_check()
> drm_plane_helper_funcs.atomic_check()

Right, but that's between objects, not between drm_$OBJECT_funcs and
drm_$OBJECT_helper_funcs. So conflicts for a single given driver is unlikely,
and can be solved by using, say, $DRIVER_crtc_atomic_check and
$DRIVER_plane_atomic_check.

> Interestingly, drm_mode_config_helper_funcs does not have an
> atomic_check() callback, but drm_mode_config_funcs has.
>
> > > Anything else confuses the casual reader. Perhaps the real question is whether
> > > the structures should have "helper" in their name in the first place?
> >
> > Those structures are meant for functions used by the helpers, they are not
> > helper functions.
>
> That might be how they started, but to me it looks like all these helpers
> are no longer helpers, but part of the core...

They are part of the core, but very much optional still. i915 doesn't use a lot
of helpers, vc4 (used to?) rolls its own atomic_commit implementation, etc. It's
really not uncommon.

Maxime

Attachment: signature.asc
Description: PGP signature