Re: [RFC][PATCH 12/17] x86/cpu: Rename original retbleed return thunk

From: Peter Zijlstra
Date: Wed Aug 09 2023 - 10:23:15 EST


On Wed, Aug 09, 2023 at 10:20:31AM -0400, Josh Poimboeuf wrote:
> On Wed, Aug 09, 2023 at 09:12:30AM +0200, Peter Zijlstra wrote:
> > +++ b/tools/objtool/check.c
> > @@ -455,7 +455,12 @@ static int decode_instructions(struct ob
> > return -1;
> > }
> >
> > - if (func->return_thunk || !strcmp(func->name, "srso_safe_ret") || func->alias != func)
> > + /*
> > + * Both zen_return_thunk() and srso_safe_ret() are embedded inside
> > + * another instruction and objtool doesn't grok that. Skip validating them.
> > + */
> > + if (!strcmp(func->name, "zen_return_thunk") ||
> > + !strcmp(func->name, "srso_safe_ret") || func->alias != func)
>
> Hm, speaking of renaming they should probably be called
> retbleed_return_thunk() and srso_return_thunk().

Yes, clearly naming is better in daylight. Let me regex that.