Re: [PATCH v2] staging: vt6655: replace camel case by snake case

From: Greg KH
Date: Wed Aug 09 2023 - 08:20:25 EST


On Sat, Aug 05, 2023 at 02:29:04PM +0530, Pavan Bobba wrote:
> Replace array name of camel case by snake case. Issue found
> by checkpatch
>
> Signed-off-by: Pavan Bobba <opensource206@xxxxxxxxx>
> ---
> v1 -> v2: 1.character '_' added in the array name "byvt3253b0_rfmde"
> 2. typo in the subject line "small case" corrected with the
> proper word "snake case"
>
> drivers/staging/vt6655/baseband.c | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/staging/vt6655/baseband.c b/drivers/staging/vt6655/baseband.c
> index 0e135af8316b..8b913c64845c 100644
> --- a/drivers/staging/vt6655/baseband.c
> +++ b/drivers/staging/vt6655/baseband.c
> @@ -499,7 +499,7 @@ static const unsigned char by_vt3253_init_tab_rfmd[CB_VT3253_INIT_FOR_RFMD][2] =
> };
>
> #define CB_VT3253B0_INIT_FOR_RFMD 256
> -static const unsigned char byVT3253B0_RFMD[CB_VT3253B0_INIT_FOR_RFMD][2] = {
> +static const unsigned char byvt3253b0_rfmd[CB_VT3253B0_INIT_FOR_RFMD][2] = {

The "by" here means "byte", a horrible naming scheme that was popular in
the 1990's when C compilers would not check the types of variables. No
need for that here, this should just be "vt3253b0_rfmd", right?

thanks,

greg k-h