Re: [PATCH V2] x86/hyperv: Rename hv_isolation_type_snp/en_snp() to isol_type_snp_paravisor/enlightened()

From: Tianyu Lan
Date: Fri Jul 28 2023 - 10:22:35 EST


On 7/28/2023 10:53 AM, Michael Kelley (LINUX) wrote:
@@ -268,7 +268,7 @@ static inline void hv_sev_init_mem_and_cpu(void) {}
static int hv_snp_boot_ap(int cpu, unsigned long start_ip) {}
#endif

-extern bool hv_isolation_type_snp(void);
+extern bool hv_isol_type_snp_paravisor(void);
This declaration of hv_isolation_type_snp() also occurs twice
in include/asm-generic/mshyperv.h. I think this one can be
dropped entirely rather than renamed since
include/asm-generic/mshyperv.h is #include'd at the bottom of
this file, and there is no user in between.

hv_isolation_type_snp() is used in several architecture
independent source code files, so having it declared in
include/asm-generic/mshyperv.h makes sense rather than
being in an architecture-specific version of mshyperv.h.


Agree. Will update in the next version.