Re: [PATCH RFC 3/7] blk-mq: support to track active queues from blk_mq_tags

From: Bart Van Assche
Date: Thu Jul 06 2023 - 14:01:42 EST


On 6/18/23 09:07, Yu Kuai wrote:
@@ -737,6 +738,7 @@ struct request *blk_mq_alloc_request_hctx(struct request_queue *q,
struct tag_sharing_ctl {
unsigned int active_queues;
unsigned int share_queues;
+ struct list_head head;
};

Please add a comment that explains that 'head' is the head of a list with
tag_sharing.node entries.

+struct tag_sharing {
+ struct list_head node;
+};

Data structure names typically are a noun. Above I see a name that ends with a
verb. Would "shared_tag_info" or "tag_sharing_info" perhaps be a better name?

Thanks,

Bart.