Re: [PATCH v3 2/6] gfs2: Replace kmap_atomic()+memcpy by memcpy_from_page()

From: Fabio M. De Francesco
Date: Sat Jul 01 2023 - 07:17:28 EST


On giovedì 29 giugno 2023 23:50:07 CEST Deepak R Varma wrote:
> kmap_atomic() is deprecated in favor of kmap_local_{folio,page}().
>
> kmap_atomic() disables page-faults and preemption (the latter only for
> !PREEMPT_RT kernels), However, the code within the mapping/un-mapping in
> gfs2_internal_read() does not depend on the above-mentioned side effects.
>
> Further, memcpy_{from,to}_page() wrappers combine the
> {kmap, unmap}_local_page() blocks when they are intended exclusively to
> copy contents from/to the temporary mapped page. So, replace the
> kmap_atomic()/kunmap_automic()

s/kunmap_automic/kunmap_atomic/

> block by the memcpy_from_page() API call.
> This change allows to tidy-up code and also eliminate unused variable p.
>
> Suggested-by: Fabio M. De Francesco <fmdefrancesco@xxxxxxxxx>

I don't like to read the list of the functions replaced by the
memcpy_from_page() helper in the subject of the patch. These details are
better suited in commit messages.

Furthermore, you have not been consistent: "kmap_atomic()+memcpy" contains
parentheses only in one of the two functions. Both or none.

The thing that really matters here is that You are replacing the deprecated
kmap_atomic() with kmap_local_page(). This is what the subject should show.

Please cite the use of the suited helper _only_ within the commit message and
explain why it is preferred to open code kmap_local_page() + memcpy() +
kunmap_local().

> Signed-off-by: Deepak R Varma <drv@xxxxxxxxx>
> ---
> Changes in v3:
> - Split as a separate patch for conversion in gfs2_internal_read()


> - Use memcpy_from_page() as suggested by Fabio and Andreas G
> - Included split version in patch set
>
> Changes in v2:
> - Update patch description to correct the replacement function name
> from kmap_local_folio to kmap_local _page
>
>
>
> fs/gfs2/aops.c | 9 ++++-----
> 1 file changed, 4 insertions(+), 5 deletions(-)
>
> diff --git a/fs/gfs2/aops.c b/fs/gfs2/aops.c
> index 3eac4f2f5c27..f47fed657763 100644
> --- a/fs/gfs2/aops.c
> +++ b/fs/gfs2/aops.c
> @@ -489,7 +489,6 @@ int gfs2_internal_read(struct gfs2_inode *ip, char *buf,
> loff_t *pos, unsigned copied = 0;
> unsigned amt;
> struct page *page;
> - void *p;
>
> do {
> page = read_cache_page(mapping, index, gfs2_read_folio,
NULL);
> @@ -498,12 +497,12 @@ int gfs2_internal_read(struct gfs2_inode *ip, char
*buf,
> loff_t *pos, continue;
> return PTR_ERR(page);
> }
> - p = kmap_atomic(page);
> - amt = size - copied;
> if (offset + size > PAGE_SIZE)
> amt = PAGE_SIZE - offset;
> - memcpy(buf + copied, p + offset, amt);
> - kunmap_atomic(p);
> + else
> + amt = size - copied;

This is a different logical change. Please put it in a different patch with
proper subject and commit message.

Thanks,

Fabio

> +
> + memcpy_from_page(buf, page, offset, amt);
> put_page(page);
> copied += amt;
> index++;
> --
> 2.34.1