Re: [RFC PATCH V3 5/6] sched/fair: Add trivial fair server

From: Daniel Bristot de Oliveira
Date: Fri Jun 16 2023 - 09:19:31 EST


On 6/16/23 15:12, Peter Zijlstra wrote:
> On Fri, Jun 16, 2023 at 03:00:57PM +0200, Daniel Bristot de Oliveira wrote:
>> On 6/16/23 14:59, Peter Zijlstra wrote:
>>> On Thu, Jun 08, 2023 at 05:58:17PM +0200, Daniel Bristot de Oliveira wrote:
>>>> +void fair_server_init(struct rq *rq)
>>>> +{
>>>> + struct sched_dl_entity *dl_se = &rq->fair_server;
>>>> +
>>>> + init_dl_entity(dl_se);
>>>> +
>>>> + dl_se->dl_runtime = TICK_NSEC;
>>>> + dl_se->dl_deadline = 20 * TICK_NSEC;
>>>> + dl_se->dl_period = 20 * TICK_NSEC;
>>>> +
>>>> + dl_server_init(dl_se, rq, fair_server_has_tasks, fair_server_pick);
>>>> +}
>>>
>>> These here numbers should obviously become a tunable somewhere... :-)
>>
>> From sched_rt_runtime and sched_rt_period, no?
>
> Well, probably new names. IIRC those are also limits on the whole
> rt-cgroup mess, so e can't trivially change it without also ripping all
> that out, and that's a little bit more work.
>
> Ripping out the basic throttle is much simpler than replacing all that
> and should be done earlier.
>

Life is easier then. Should them be a sysctl?

Like:
kernel.sched_other_min_runtime_us ?
kernel.sched_other_min_period_us ?

I bet you can come up with better names.

-- Daniel