Re: [PATCH] x86/kexec: Add a comment to relocate_kernel() for better readability

From: kirill . shutemov
Date: Wed Jun 07 2023 - 07:20:08 EST


On Wed, Jun 07, 2023 at 10:39:10PM +1200, Kai Huang wrote:
> The reason to save %rcx to %r11 before calling swap_pages isn't that
> obvious w/o looking into the swap_pages itself. Add a comment to
> improve the readability.
>
> Signed-off-by: Kai Huang <kai.huang@xxxxxxxxx>
> ---
> arch/x86/kernel/relocate_kernel_64.S | 4 ++++
> 1 file changed, 4 insertions(+)
>
> diff --git a/arch/x86/kernel/relocate_kernel_64.S b/arch/x86/kernel/relocate_kernel_64.S
> index 56cab1bb25f5..97deae3c5e6c 100644
> --- a/arch/x86/kernel/relocate_kernel_64.S
> +++ b/arch/x86/kernel/relocate_kernel_64.S
> @@ -169,6 +169,10 @@ SYM_CODE_START_LOCAL_NOALIGN(identity_mapped)
> wbinvd
> 1:
>
> + /*
> + * Save the preserve_context to %r11 as
> + * swap_pages clobbers %rcx.
> + */

Line split is not needed. It fits nicely under 80-characters.

+ /* Save the preserve_context to %r11 as swap_pages clobbers %rcx. */

Otherwise, LGTM.

> movq %rcx, %r11
> call swap_pages
>
>
> base-commit: 409bf2895d71bb68bc5b8589036e5ed1ca30bada
> --
> 2.40.1
>

--
Kiryl Shutsemau / Kirill A. Shutemov