Re: [PATCH bpf-next v2 4/5] selftests/bpf: rename bpf_fentry_test{7,8,9} to bpf_fentry_test_ptr*

From: Menglong Dong
Date: Fri Jun 02 2023 - 05:45:13 EST


On Fri, Jun 2, 2023 at 3:03 PM <menglong8.dong@xxxxxxxxx> wrote:
>
> From: Menglong Dong <imagedong@xxxxxxxxxxx>
>
> To make it more clear, let's make the N in bpf_fentry_testN as the count
> of target function arguments. Therefore, let's rename
> bpf_fentry_test{7,8,9} to bpf_fentry_test_ptr{1,2,3}.
>
> Meanwhile, to stop the checkpatch complaining, move the "noinline" ahead
> of "int".
>
> Reviewed-by: Jiang Biao <benbjiang@xxxxxxxxxxx>
> Signed-off-by: Menglong Dong <imagedong@xxxxxxxxxxx>
> ---
> net/bpf/test_run.c | 12 +++++-----
> .../selftests/bpf/prog_tests/bpf_cookie.c | 24 +++++++++----------
> .../bpf/prog_tests/kprobe_multi_test.c | 16 ++++++-------
> .../testing/selftests/bpf/progs/fentry_test.c | 16 ++++++-------
> .../testing/selftests/bpf/progs/fexit_test.c | 16 ++++++-------
> .../selftests/bpf/progs/get_func_ip_test.c | 2 +-
> .../selftests/bpf/progs/kprobe_multi.c | 12 +++++-----
> .../bpf/progs/verifier_btf_ctx_access.c | 2 +-
> .../selftests/bpf/verifier/atomic_fetch_add.c | 4 ++--
> 9 files changed, 52 insertions(+), 52 deletions(-)
>

Sadly, this patch breaks the "bpf_fentry_test?" pattern in
kprobe_multi.c and kprobe_multi_test.c.

I'm considering changing the "bpf_fentry_test?" to
"bpf_fentry_test*" to solve this problem.

Another option, we can remove kretprobe_test7_result
and kretprobe_test8_result and only check
bpf_fentry_test1~6 in kprobe_multi_check.

Or......maybe I shouldn't rename them?