[PATCH] Documentation: kunit: Rename references to kunit_abort()

From: David Gow
Date: Thu Jun 01 2023 - 23:54:16 EST


The kunit_abort() function has been renamed __kunit_abort(), update the
references to it in the documentation.

Suggested-by: Daniel Latypov <dlatypov@xxxxxxxxxx>
Signed-off-by: David Gow <davidgow@xxxxxxxxxx>
---
Documentation/dev-tools/kunit/architecture.rst | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/Documentation/dev-tools/kunit/architecture.rst b/Documentation/dev-tools/kunit/architecture.rst
index e95ab05342bb..f335f883f8f6 100644
--- a/Documentation/dev-tools/kunit/architecture.rst
+++ b/Documentation/dev-tools/kunit/architecture.rst
@@ -119,9 +119,9 @@ All expectations/assertions are formatted as:
terminated immediately.

- Assertions call the function:
- ``void __noreturn kunit_abort(struct kunit *)``.
+ ``void __noreturn __kunit_abort(struct kunit *)``.

- - ``kunit_abort`` calls the function:
+ - ``__kunit_abort`` calls the function:
``void __noreturn kunit_try_catch_throw(struct kunit_try_catch *try_catch)``.

- ``kunit_try_catch_throw`` calls the function:
--
2.41.0.rc2.161.g9c6817b8e7-goog