Re: [PATCH] iommu: Add Kconfig help text for IOMMU_SVA

From: Jason Gunthorpe
Date: Tue May 09 2023 - 19:06:14 EST


On Mon, May 08, 2023 at 10:17:53AM -0700, Linus Torvalds wrote:

> That said, the arm-smmu-v3-sva.c code clearly *also* uses pasid,
> except it seems to really want to call it "ssid".

This code is incorrect.. It is using the mm->pasid to try to deliver
an invalidation, but our new design does not restrict the userspace to
a single PASID, thus it will fail to properly synchronize the ATC in
some degenerate cases. In general the driver needs to be able to go
over a list of PASIDs that the domains are linked to and replicate
invalidations (of any sort) to the whole list.

It is still a WIP to make this driver implement the driver contract
for PASID logic properly.

> Now, "SSID" is a completely horrible name, as I immediately realized
> when I tried to google for it. So arm64 is just wrong, and we're most
> definitely continuing to call it PASID.

Yes, PASID comes from PCIe so we are using that.

> I'd lean towards just "CONFIG_MM_PASID" or something, but at some
> point this is bikeshedding, and I don't know about any possible
> non-iommu direct uses?

I don't think there is any other use, IOMMU should be the only
consumer of PASID, so it is a fine name as well.

Thanks,
Jason