Re: [PATCH v4 4/6] io_uring: rsrc: avoid use of vmas parameter in pin_user_pages()

From: Jens Axboe
Date: Wed Apr 19 2023 - 12:35:18 EST


On 4/18/23 9:49?AM, Lorenzo Stoakes wrote:
> We are shortly to remove pin_user_pages(), and instead perform the required
> VMA checks ourselves. In most cases there will be a single VMA so this
> should caues no undue impact on an already slow path.
>
> Doing this eliminates the one instance of vmas being used by
> pin_user_pages().

First up, please don't just send single patches from a series. It's
really annoying when you are trying to get the full picture. Just CC the
whole series, so reviews don't have to look it up separately.

So when you're doing a respin for what I'll mention below and the issue
that David found, please don't just show us patch 4+5 of the series.

> diff --git a/io_uring/rsrc.c b/io_uring/rsrc.c
> index 7a43aed8e395..3a927df9d913 100644
> --- a/io_uring/rsrc.c
> +++ b/io_uring/rsrc.c
> @@ -1138,12 +1138,37 @@ static int io_buffer_account_pin(struct io_ring_ctx *ctx, struct page **pages,
> return ret;
> }
>
> +static int check_vmas_locked(unsigned long addr, unsigned long len)
> +{
> + struct file *file;
> + VMA_ITERATOR(vmi, current->mm, addr);
> + struct vm_area_struct *vma = vma_next(&vmi);
> + unsigned long end = addr + len;
> +
> + if (WARN_ON_ONCE(!vma))
> + return -EINVAL;
> +
> + file = vma->vm_file;
> + if (file && !is_file_hugepages(file))
> + return -EOPNOTSUPP;
> +
> + /* don't support file backed memory */
> + for_each_vma_range(vmi, vma, end) {
> + if (vma->vm_file != file)
> + return -EINVAL;
> +
> + if (file && !vma_is_shmem(vma))
> + return -EOPNOTSUPP;
> + }
> +
> + return 0;
> +}

I really dislike this naming. There's no point to doing locked in the
naming here, it just makes people think it's checking whether the vmas
are locked. Which is not at all what it does. Because what else would we
think, there's nothing else in the name that suggests what it is
actually checking.

Don't put implied locking in the naming, the way to do that is to do
something ala:

lockdep_assert_held_read(&current->mm->mmap_lock);

though I don't think it's needed here at all, as there's just one caller
and it's clearly inside. You could even just make a comment instead.

So please rename this to indicate what it's ACTUALLY checking.

--
Jens Axboe