RE: [PATCH v8 4/4] platform/x86/intel/pmc: core: Report duration of time in HW sleep state

From: Limonciello, Mario
Date: Thu Apr 13 2023 - 18:40:53 EST


[Public]



> -----Original Message-----
> From: Ilpo Järvinen <ilpo.jarvinen@xxxxxxxxxxxxxxx>
> Sent: Thursday, April 13, 2023 04:24
> To: Limonciello, Mario <Mario.Limonciello@xxxxxxx>
> Cc: Box David E <david.e.box@xxxxxxxxx>; jstultz@xxxxxxxxxx;
> pavel@xxxxxx; svenva@xxxxxxxxxxxx; Rajneesh Bhardwaj
> <irenic.rajneesh@xxxxxxxxx>; S-k, Shyam-sundar <Shyam-sundar.S-
> k@xxxxxxx>; rrangel@xxxxxxxxxxxx; Jain Rajat <rajatja@xxxxxxxxxx>;
> hdegoede@xxxxxxxxxx; Mark Gross <markgross@xxxxxxxxxx>; platform-
> driver-x86@xxxxxxxxxxxxxxx; LKML <linux-kernel@xxxxxxxxxxxxxxx>
> Subject: Re: [PATCH v8 4/4] platform/x86/intel/pmc: core: Report duration of
> time in HW sleep state
>
> On Wed, 12 Apr 2023, Mario Limonciello wrote:
>
> > intel_pmc_core displays a warning when the module parameter
> > `warn_on_s0ix_failures` is set and a suspend didn't get to a HW sleep
> > state.
> >
> > Report this to the standard kernel reporting infrastructure so that
> > userspace software can query after the suspend cycle is done.
> >
> > Signed-off-by: Mario Limonciello <mario.limonciello@xxxxxxx>
> > ---
> > v7->v8:
> > * Report max sleep as well
> > ---
> > drivers/platform/x86/intel/pmc/core.c | 3 +++
> > 1 file changed, 3 insertions(+)
> >
> > diff --git a/drivers/platform/x86/intel/pmc/core.c
> b/drivers/platform/x86/intel/pmc/core.c
> > index 925c5d676a43..f9677104353d 100644
> > --- a/drivers/platform/x86/intel/pmc/core.c
> > +++ b/drivers/platform/x86/intel/pmc/core.c
> > @@ -1153,6 +1153,7 @@ static int pmc_core_probe(struct platform_device
> *pdev)
> > pmc_core_do_dmi_quirks(pmcdev);
> >
> > pmc_core_dbgfs_register(pmcdev);
> > + pm_report_max_hw_sleep(((1UL << 32) - 1) *
> pmc_core_adjust_slp_s0_step(pmcdev, 1));
>
> Technically this is FIELD_MAX(SLP_S0_RES_COUNTER_MASK) *
> pmc_core_adjust...?
> Where the define is:
> #define SLP_S0_RES_COUNTER_MASK GENMASK(31, 0)

That's fine by me to switch it over, it certainly makes it a lot more readable.
I took the value from @Box David E to use suggested in v7, so what are your
thoughts?

The current version has an overflow error reported by the robot for i386, so it
definitely needs some sort of change.

>
> >
> > device_initialized = true;
> > dev_info(&pdev->dev, " initialized\n");
> > @@ -1214,6 +1215,8 @@ static inline bool pmc_core_is_s0ix_failed(struct
> pmc_dev *pmcdev)
> > if (pmc_core_dev_state_get(pmcdev, &s0ix_counter))
> > return false;
> >
> > + pm_report_hw_sleep_time((u32)(s0ix_counter - pmcdev-
> >s0ix_counter));
> > +
> > if (s0ix_counter == pmcdev->s0ix_counter)
> > return true;
> >
> >
>
> --
> i.