Re: [PATCH 10/13] ipvs: Rename kfree_rcu() to kfree_rcu_mightsleep()

From: Julian Anastasov
Date: Wed Feb 01 2023 - 11:12:48 EST



Hello,

On Wed, 1 Feb 2023, Pablo Neira Ayuso wrote:

> Hi,
>
> On Wed, Feb 01, 2023 at 04:09:51PM +0100, Uladzislau Rezki (Sony) wrote:
> > The kfree_rcu()'s single argument name is deprecated therefore
> > rename it to kfree_rcu_mightsleep() variant. The goal is explicitly
> > underline that it is for sleepable contexts.
> >
> > Cc: Julian Anastasov <ja@xxxxxx>
> > Cc: Pablo Neira Ayuso <pablo@xxxxxxxxxxxxx>
> > Cc: Jiri Wiesner <jwiesner@xxxxxxx>
> > Signed-off-by: Uladzislau Rezki (Sony) <urezki@xxxxxxxxx>
> > ---
> > net/netfilter/ipvs/ip_vs_est.c | 2 +-
> > 1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/net/netfilter/ipvs/ip_vs_est.c b/net/netfilter/ipvs/ip_vs_est.c
> > index ce2a1549b304..a39baf6d1367 100644
> > --- a/net/netfilter/ipvs/ip_vs_est.c
> > +++ b/net/netfilter/ipvs/ip_vs_est.c
> > @@ -549,7 +549,7 @@ void ip_vs_stop_estimator(struct netns_ipvs *ipvs, struct ip_vs_stats *stats)
> > __set_bit(row, kd->avail);
> > if (!kd->tick_len[row]) {
> > RCU_INIT_POINTER(kd->ticks[row], NULL);
> > - kfree_rcu(td);
>
> I also found this kfree_rcu() without rcu_head call a few weeks ago.
>
> @Wiesner, @Julian: Any chance this can be turned into kfree_rcu(td, rcu_head); ?

Yes, as simple as this:

diff --git a/include/net/ip_vs.h b/include/net/ip_vs.h
index c6c61100d244..6d71a5ff52df 100644
--- a/include/net/ip_vs.h
+++ b/include/net/ip_vs.h
@@ -461,6 +461,7 @@ void ip_vs_stats_free(struct ip_vs_stats *stats);

/* Multiple chains processed in same tick */
struct ip_vs_est_tick_data {
+ struct rcu_head rcu_head;
struct hlist_head chains[IPVS_EST_TICK_CHAINS];
DECLARE_BITMAP(present, IPVS_EST_TICK_CHAINS);
DECLARE_BITMAP(full, IPVS_EST_TICK_CHAINS);
diff --git a/net/netfilter/ipvs/ip_vs_est.c b/net/netfilter/ipvs/ip_vs_est.c
index df56073bb282..25c7118d9348 100644
--- a/net/netfilter/ipvs/ip_vs_est.c
+++ b/net/netfilter/ipvs/ip_vs_est.c
@@ -549,7 +549,7 @@ void ip_vs_stop_estimator(struct netns_ipvs *ipvs, struct ip_vs_stats *stats)
__set_bit(row, kd->avail);
if (!kd->tick_len[row]) {
RCU_INIT_POINTER(kd->ticks[row], NULL);
- kfree_rcu(td);
+ kfree_rcu(td, rcu_head);
}
kd->est_count--;
if (kd->est_count) {

I was about to reply to Uladzislau Rezki but his patchset
looks more like a renaming, so I'm not sure how we are about
to integrate this change, as separate patch or as part of his
patchset. I don't have preference, just let me know how to
handle it.

Regards

--
Julian Anastasov <ja@xxxxxx>