[PATCH 05/13] lib/test_vmalloc.c: Rename kvfree_rcu() to kvfree_rcu_mightsleep()

From: Uladzislau Rezki (Sony)
Date: Wed Feb 01 2023 - 10:10:54 EST


The kvfree_rcu()'s single argument name is deprecated therefore
rename it to kvfree_rcu_mightsleep() variant. The goal is explicitly
underline that it is for sleepable contexts.

Signed-off-by: Uladzislau Rezki (Sony) <urezki@xxxxxxxxx>
---
lib/test_vmalloc.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/lib/test_vmalloc.c b/lib/test_vmalloc.c
index f90d2c27675b..6d8c5c0afd53 100644
--- a/lib/test_vmalloc.c
+++ b/lib/test_vmalloc.c
@@ -328,7 +328,7 @@ kvfree_rcu_1_arg_vmalloc_test(void)
return -1;

p->array[0] = 'a';
- kvfree_rcu(p);
+ kvfree_rcu_mightsleep(p);
}

return 0;
--
2.30.2