Re: [PATCH v3 03/10] KEYS: X.509: Parse Basic Constraints for CA

From: Mimi Zohar
Date: Wed Jan 04 2023 - 17:39:13 EST


On Wed, 2023-01-04 at 20:14 +0000, Eric Snowberg wrote:
>
> > On Jan 4, 2023, at 5:29 AM, Jarkko Sakkinen <jarkko@xxxxxxxxxx> wrote:
> >
> > On Thu, Dec 15, 2022 at 06:10:04AM -0500, Mimi Zohar wrote:
> >>> diff --git a/crypto/asymmetric_keys/x509_parser.h b/crypto/asymmetric_keys/x509_parser.h
> >>> index a299c9c56f40..7c5c0ad1c22e 100644
> >>> --- a/crypto/asymmetric_keys/x509_parser.h
> >>> +++ b/crypto/asymmetric_keys/x509_parser.h
> >>> @@ -38,6 +38,7 @@ struct x509_certificate {
> >>> bool self_signed; /* T if self-signed (check unsupported_sig too) */
> >>> bool unsupported_sig; /* T if signature uses unsupported crypto */
> >>> bool blacklisted;
> >>> + bool root_ca; /* T if basic constraints CA is set */
> >>> };
> >>
> >> The variable "root_ca" should probably be renamed to just "ca", right?
> >
> > Perhaps is_ca?
>
> I am open to renaming this, but need an agreement on whether the “is_” should be used or not:
>
> https://lore.kernel.org/lkml/b28ea211d88e968a5487b20477236e9b507755f4.camel@xxxxxxxxxxxxx/

Examples of both functions and variables exist that are prefixed with
"is_". One is a question; the other a statement. Naming the
variable "is_ca" and using it like "if (cert->is_ca)" does make sense.

--
thanks,

Mimi